Windows 8 and 8.1 Forums


Can't get on Internet - Wi-fi Adapter suddenly not w9orkin

  1. #1


    Posts : 2
    windows 8.1

    Can't get on Internet - Wi-fi Adapter suddenly not w9orkin


    Right after a recent update to Windows 8.1 64-bit, my wi-fi adapter stopped working and I was unable to connect to the Internet on that computer, an ASUS M11BB with AMD A10-6700 16 GB ram. There is a yellow exclamation point on the adapter in the device manager. I tried installing the latest drivers from ASUS (both chipset and wi-fi adapter drivers) and even restored the OS to a point 3 weeks ago when everything was working, and the problem remains.

    I figured it was a hardware problem on the internal board for the ASUS Wi-Fi adapter. I bought an external USB wi-fi adapter that said on the box that it was compatible with Windows 8.1 but when I tried to install it in one of the USB ports, it failed with a message that the OS was not supported. How can that be? It said on the box it was compatible with 8.1 so what's the problem? Has MS updated 8.1 such that Wi-Fi adapters/device drivers are not compatible any more?

    This is a serious issue. I cannot even troiubleshoot the problem on that computer because it won't connect to the internet. I have had to use this (an alternate computer) just to post this. Can anyone help?

      My System SpecsSystem Spec

  2. #2


    Forever West
    Posts : 591
    WinVista, Win7, Win8.1, Win10, Mac OS X 10.10, Linux Mint 17.1


    The question I'd ask is if the machine's Ethernet/NIC has been tried with a cable to the Router and if it works? If the icon in the Notification Area shows it is connected I'd then open a Command Prompt window to type ping anydomain.com to see if it can be reached. I just checked and using ping google.com worked, some sites don't allow it. If that doesn't work try the command ipconfig to see if your Router is reachable.
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    windows 8.1


    I drove to Fry's and they sold me a different external USB wi-fi adapter/dongle that worked. I didn't try a direct cable connection because the router is too far away from the PC and I don't have a cable that long. I am going to mark this as solved. Thank you for your advice.
      My System SpecsSystem Spec

Can't get on Internet - Wi-fi Adapter suddenly not w9orkin
Related Threads
Internet adapter issues in Drivers & Hardware
Hey all, so I run my laptop wirelessly 99% of the time, recently i have been getting messed up response out of it.. So I will be using it and it will just lost signal so i do the usual, try the crappy windows "automatic troubleshooter" that is 50/50 sometimes works sometimes doesnt, so IF...
It's definitely not a hardware problem as one minute it's all working, then it suddenly stops. I've tried everything. My sound card drivers are all up to date, it also happens at the same time as youtube videos stop playing on google chrome (despite them loading), windows media player is unable to...
Hi, I've been browsing your forums for a solution to the netio.sys BSOD without any success. I have Free Download Manager and use it to download files and torrents. I am a US native currently in Ivory Coast, using a Wimax USB adapter BM328 through mtn.ci The link below includes the latest...
Does your WMP suddenly close? in General Support
I've had this issue always ever since I installed 8.1, across my 100 formats that I've done, every single one of them had this issue. When I play an MP3, it would run fine for about 30 seconds or so, then suddenly WMP would say it encountered an error and would close. Now I can simply...
Ok, this is my first post, hope this is the right place to post this. I have noticed that my internet speed is very slow in Windows 8, other people have somewhat the same problem, however mine is noticeably slower. In Windows 7 I got 330Kb/s Download and 40Kb/s Upload, which is my max, but in...
Hello, I just upgraded to windows 8 from vista, and I am having major problems ´connecting a wireless adapter so I can get to the internet. This is what I tried: First, I tried the adapter I was using with Vista-Netgear WNA1100. I installed using compatibility settings to Win XP...
Solved Suddenly no more sounds in Sound & Audio
I dont know what happened but all of a sudden i cant hear any sound. Everything worked perfectly up untill now. It still acts like its playing sounds from what i can tell from the sound manager. However im not getting anything , not even on my headphones.I've tried looking up on forums but couldnt...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook