Windows 8 and 8.1 Forums


External HDDs disconnect/reconnect on certain USB Port

  1. #1


    Posts : 11
    Windows 8 Pro

    External HDDs disconnect/reconnect on certain USB Port


    Hey there!

    the tl;dr is that external hdds keep disconnecting/reconnecting when connected to a certain usb port. the story below might help you guys help me as it kinda shows what I've tried already and when the problems started

    when it started/system backstory:
    I seem to be having problems with a certain usb port. I have a lenovo y500 laptop with 2 usb ports on the left side, and 1 on the right. I'm not sure if they all support usb 3, but at least one does (I'll look up the specifics on this later/if relevant).

    I own several external hdds (some usb2, some usb3) and up until recently, have never encountered any problems with hooking more than 1 up to my laptop. I recently purchased another WD My Book 4TB, and proceeded to hook that one and one of the same type that I already owned (and that has/had worked flawlessly since I bought it months ago), up to my laptop. Everything seemed fine. However, the next time I started up my laptop, with the 2 drives still attached, the new drive attached to one of the left usb ports, started acting up right away. Constantly disconnecting/reconnecting. Which it hadn't done at all the previous day/night, when I had used it for quite a lot of hours.


    what I've tried already:
    Since I found a lot of IO errors in the event log, I figured it was probably the hdd dying. However, when I hooked up another external hdd today, one that I have fully checked less than a week ago, and it started to do the exact same thing, I figured it was probably something with the usb port. I had my suspicions and thus have been avoiding using that usb port to check new external hdds since the initial problems, turns out I was probably right.

    I have tried uninstalling all the usb devices with generic names, and this seems to have helped somewhat, but the problem persists (albeit with a much much lower frequency).

    I have also already looked at the power settings and disabled usb selective suspend.

    NOTE: All of the external hdds mentioned are externally powered.


    Please help me fix this, it's so so annoying.


      My System SpecsSystem Spec

  2. #2


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Most likely a power problem. The rated power of 500ma isn't much and can easily be overloaded. The power circuit to the port in question may be going bad. If so it won't make any difference if the drive is externally powered.
      My System SpecsSystem Spec

  3. #3


    Posts : 11
    Windows 8 Pro


    Quote Originally Posted by popeye View Post
    Most likely a power problem. The rated power of 500ma isn't much and can easily be overloaded. The power circuit to the port in question may be going bad. If so it won't make any difference if the drive is externally powered.
    this makes sense.. when I hooked up a mouse I had 0 problems at all. is there any way to test this theory?
      My System SpecsSystem Spec

  4. #4


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    I have a MyPassport drive which is totally USB powered by a single port and works fine. Only easy way I know of is to test with a drive that is solely USB powered.
      My System SpecsSystem Spec

  5. #5


    Posts : 11
    Windows 8 Pro


    Quote Originally Posted by popeye View Post
    I have a MyPassport drive which is totally USB powered by a single port and works fine. Only easy way I know of is to test with a drive that is solely USB powered.
    But how will that prove or disprove anything? I do have one of those, but if I hook that one up, and it does the same thing, nothing has changed, but also nothing has been proven. And besides, how would removing drivers make a difference to the functioning of the usb port though? If it is the usb port that's dying, why would function improve when I removed all those generic drivers? That makes no sense :s
      My System SpecsSystem Spec

  6. #6


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    I give up, just trying to help.
      My System SpecsSystem Spec

  7. #7


    Posts : 11
    Windows 8 Pro


    Quote Originally Posted by popeye View Post
    I give up, just trying to help.
    No reason to get offended, I'm just honestly wondering how what you suggested would prove or disprove anything. I sincerely don't see how it would..
      My System SpecsSystem Spec

External HDDs disconnect/reconnect on certain USB Port
Related Threads
I have a lenovo b570e laptop and am running Windows 8.1. I recently bought a new monitor (ASUS ve248h) to use as a dual monitor along side my own laptop however upon connecting the HDMI cable with the monitor it doesn't appear to work. I have tried updating the drivers and the hdmi port does...
I have 3 monitors connected to an AMD HD5770 graphics card. Two monitors connect via HDMI, and the third through a Sapphire Active DisplayPort->DVI adaptor. Things have been working fine for years, but recently I started sleeping my computer when I am not using it during the day, as opposed to my...
Hi, I've looked through the forum but cant find a solution I have Acer X3995 running windows 8.1 I have a 4 port USB 3 hub connected (with 4 x USB drives attached) and 1 portable USB 3 drive. When copying large amounts of data to the drives they will disconnect from the system and then...
I want to reach, that every Storage-Device, which gets connected to the computer, is automatically read-only. In Windows 7 there was an registry hack (StorageDevicePolicies -> WriteProtect) , but in Windows 8 this doesnt work any more. So what is a suitable alternative? PS: Not only users...
47143 47144 47145 so i opened my port 25565 (or so i thought) went to test to see if its open on multiple sites and....all of them say its closed. :confused:
CDMA software requires a COM port to communicate with a cell phone. I'm using HW Virtual Serial Port v3.1.2 (single port, standalone install). I have a separate modem and router. My Win8.1 PC is hardwired to the modem. Windows firewall is off. Windows Defender is off. Motorola Mobile Drivers...
First off, If this is in the correct location I humbly apologize in advance. I've been searching like crazy and haven't found anything helpful (I may just not be looking in the right place.) ;) This may take a bit of explanation so please be patient and bare with me! Situation: I have...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook