I have bought a Dell Inspiron 1545 laptop in 2009 which it previously had Windows 7 and everything worked fine until this print spooler problem occurs just happened in mid-2011 and until now with Windows 8.1 upgraded which I have done yesterday.

Everytime I go to Control Panel > Devices and Printers > Add a printer the problem occurs that the print spooler service is not running, this is what would Microsoft call it "Windows can't open Add Printer (Paragraph line) The local print spooler service is not running. Please restart the spooler or restart the machine."
I have tried this by going in to Services and Start the spooler service, but somehow another error message which come up saying "Windows could not start the Spooler service on Local Computer. (Paragraph line) Error 1053: The service did not respond to the start or control request in a timely fashion."

Is there a way to solve this issue?
Please reply back if you want pictures showing error messages instead of written text just to make it easier, please reply back.


Yours Sincerely,