Windows 8 and 8.1 Forums


CD drive does not respond

  1. #1


    Posts : 1
    Windows XP

    CD drive does not respond


    I am running Windows 8 on a laptop. Until recently, everything worked. Now, my CD drive does not read the disk or respond to an eject, but it shows up in Device manager. When I tried to look at from a command prompt it says it cannot find the drive. Due to my fiddling around, there is now another drive letter, I, assigned to a removable drive. When I try to look at this it says that the device is not ready

    I found a suggestion for an older Windows problem that said to uninstall the drive in Device Manager, and also to uninstall the IDE controller, then reboot. In my system, I have only a SATA controller, which I assume controls both the CD/DVD drive and the hard drive. Is it safe to uninstall the SATA controller and reboot, to see if this cures the problem? I am concerned because if the SATA does not reinstall automatically, I think I will have no operating system.

    I would also like to get rid of the new drive letter and let the CD be drive d:, as it was before.

    Thank you,
    Jan

      My System SpecsSystem Spec

  2. #2


    SATA is a part of IDE standard so you do not have to actually be there. You're quite safe to uninstall CD drive in Device manager, IDE/SATA controller is obviously working as your HDD works, no need to reinstall that one.
      My System SpecsSystem Spec

CD drive does not respond
Related Threads
Since installing a large number of Windows and driver updates, the Win + X Power Users Menu has become slow to respond. Every menu item does respond, but only after a delay of 10 to 15 seconds. Previously the response was instant. Accessing any of these menu items via an alternative route still...
Hi everyone, I have a strange problem that I'm hoping one of the genius people on here will be able to help me with. My laptop is a Samsung, about 9 months old and has a pretty good spec. Suddenly, over the past few days, I've noticed that the keyboard in lagging whenever I'm logged on. ...
File Explorer - Ceases to respond, and churns in Performance & Maintenance
File Explorer - Ceases to respond, and churns sometimes . . . I don't think I'm clicking too fast, or on too many things, because it usually works how I want. Maybe it was doing a Win Defender scan, and the auto-pause takes 15 seconds to kick in? Just wondering if anyone else has noticed...
Steam and WMP do not respond in Software and Apps
so couple of days ago i couldnt get onto steam or WMP and i tried to uninstall them and reintall but nothing works...i scanned for viruses or worms ect. nothing. it just has a pop up saying not responding and my ram wasnt full it was about mid way when they frozze and nothing else was running in...
Connect to Internet Won't Respond in Network & Sharing
One day, I was having problems with my internet, so I disconnected from it. When I tried to reconnect, I couldn't. So I discontinued trying to connect to my internet. But when I tried again at another time, connect to internet wouldn't respond when I click on it. Or any of the other shortcuts. Idk...
​Read more.. Windows 8 Secure Boot: two Linux distros respond
Eight Forums Android App Eight Forums IOS App Follow us on Facebook