Windows 8 and 8.1 Forums

USB Controller working in Windows 7, but not Windows 8

  1. #1

    Posts : 3
    Windows 8.1 Professional

    USB Controller working in Windows 7, but not Windows 8

    This controller is a Logitech Gamepad F310 which is recognized as a "Dual Action" in device manager. It has always worked for me, even when the cable was twisted beyond belief to the point where I had splice the controller cable ends together to it. Even since then, it has worked on all of my machines, including my Lenovo. I have an HP Elitebook 8470p running Windows 7 that runs the controller in all manner of applications perfectly fine, yet on my laptop I use for more real gaming (my Lenovo Y510p) it does not work at all in Windows 8.1. Up until recently, both laptops would recognize the controller and use it properly, all within similar applications.

    The HP still detects the controller and uses it fine. The Lenovo, on the other hand, connects it at first - giving the windows "Device connected" sound effect, then sometimes immediately, or after a few seconds, disconnects the device. The controller, during this time, does appear in Devices and Printers and lights up. This has been tried in both USB 2.0 and 3.0 ports on both computers. Drivers were checked, uninstalled and reinstalled, and both computers are fully up to date. Any suggestions?

      My System SpecsSystem Spec

  2. #2

    Posts : 2,480
    Windows 10 Pro x64
      My System SpecsSystem Spec

  3. #3

    Penn's Forest
    Posts : 216
    Win8.1 Pro | Win10TP Pro - boot to VHD

    Quote Originally Posted by softwaremaniac View Post
    The Logitech forum doesn't promote the link very well.

    Quote Originally Posted by Dale: on Logitech Forums
    Hello CarrotandStick,
    To help resolve the issue with your logitech F310 and F710 Gamepads, try the steps provided on this thread.

    Support Specialist
    This looks very promising, but it was hard for me to see what Dale wanted the user to find.

    ...try the steps provided on this thread
    points to: Logitech Forums : Gaming : Logitech G Controllers : Logitech F710 not detected in Win 8
      My System SpecsSystem Spec

USB Controller working in Windows 7, but not Windows 8
Related Threads
Since I updated to Windows 8.1 I cannot get my PC to charge my controller. Is there anyway to get the driver I need to enable my PC to do this again?
This evening I went to use by portable USB drive and noticed it wouldn't work. I tried another port and it still didn't work. I then tried another device on the same ports and it also did not work. I opened up device manager and saw that my VIA USB xHCI controller was no longer listed under USB...
Windows 8 PC controller in Drivers & Hardware
Hello, I have run into a problem with my Windows 8 computer once in a while, it's that my PC doesn't recognize USB ported devices as supposed to, but it does recognize things such as a wireless mouse and keyboard. Now, my question is, can I buy a wired Xbox 360 controller and connect it to my...
Hi. First, im on a Lenovo Y510p Laptop. Yesterday, windows updated through windows update and when i logged into my computer, none of my usb ports were working. As in: My external mouse and keyboard were not connecting, they were working just before the update though.(they are new.) Device manager...
Hello! Sorry if this has been asked before, but I didn't find something similar. My Windows 8.1 installation started developing some problems including malware. So I decided to reinstall Windows, but in order to make it without a hurry, I used a separate disk. This way I could use the old...
I just installed a Highpoint 620 PCI-E SATA controller card into my win 8 PC. Win 8 has installed (best guess) the Microsoft Storage Spaces Controller for the Highpoint 620. And my Blu-ray burner which is connected to the 620, seems to be working. But I would like to find some dedicated...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook