Windows 8 and 8.1 Forums

Retrolink GameCube usb controller

  1. #1

    Posts : 1
    Windows 8.1

    Retrolink GameCube usb controller

    Unknown USb device, code 43 descriptor fail in device manager, for a Retrolink gamecube controller i ordered online.
    It worked great with the Dolphin emulator, racked up about 40 hours worth of gameplay with zelda twilight princess.
    While playing it just randomly, quit working, got that unknown usb device pop up on the taskbar, it went away, controller worked after some button mashing, this process repeated a few times over and over, i was eventually able to retain my anger from smashing the whole works by finishing a dungeon and saving. So i called it a night.

    Plugged it in the next day to play again, continuously getting that same pop up message saying "usb device not recognized" .
    Tried everything i could think of after running the ole google machine.
    Removed/uninstalled from device manager, rebooted, removed battery from laptop, rinse lather repeat. Followed a few other forums and went into the regedit, disabling, usb power saving setting's ect, ect.

    I have a wireless mouse which works on every usb port...
    Did virus scans, adware malware blah blah, registry cleaner, nothing works.

    Iam starting to think the controller is just a dead useless piece of plastic now?

    Figured i would try posting on a forum or two, Willing to try anything at the moment.

    As a side note, the weird thing is, I would plug the controller in as I usually would, get the usb unrecognized message, than load up dolphin, and attempt to configure/calibrate the controller, and if i hit the analogue pad back n forth, it would be recognized and picked up in the controller config window... weird.. as soon as i did that, i would get that yellow pop up window saying device malfunctioned, and than controller would be useless..

    So I uninstalled Dolphin completely, thinking it was a weird setting due to that program, but yet its still showing up with an exclamation mark in device manager...

    Could the controller just be dead due to poor craftsmanship? if that was the case wouldn't it just die completely? and not work intermittently like it did the first time i started getting this error while -playing? something sounds fishy..

    Sure it was only 25 bucks or so not even worth shipping back for a credit or exchange, just figured i would post here, cause as far as im concerned i can't fathom any reason why it would just crap out like that?

    If it was poorly constructed, what could cause a device to just glitch out like this? makes no sense. I took it apart, checked it all out, everything's still soldered and visual up to par. It has never been man handled roughly or banged around its still in mint condition.

    Sorry for the long winded explanation. I am open to suggestions or ideas. Apparently, retro link is a faceless and well nameless company, i believe if I can Find the drivers for it that may lead me to a potential solution....

      My System SpecsSystem Spec

  2. #2

    Posts : 2,627
    win8.1.1 enterprise

    If it was poorly constructed, what could cause a device to just glitch out like this? makes no sense.
    an uneducated guess ,but it could be a device driver issue ,like poorly written or not 100% compatible driver, giving its knockoff controller
      My System SpecsSystem Spec

Retrolink GameCube usb controller
Related Threads
Add a USB 3 PCIE controller in Drivers & Hardware
Hi, Have difficulty to show my Toshiba V63700-A 500gb external HD plugged in the USB 2s of my motherboard. Saw this below in Amazon (9.99) but does not mention Win8 only w7, has anybody by chance used it in w8? Also my mobo has 2 free PCIE slots, will I need anything else with them or...
Can't get USB controller to work in Drivers & Hardware
I've got a new USB controller which came with an installation CD which I ran. However I still can't get the controller to work (wanted for game use), nothing happens when I use it. It says the drivers are up to date and in the device manager it shows up as a USB Input Device under Human Interface...
X box controller in Gaming
Hi I have a wireless X box controller with the PC adaptor. I have downloaded the latest drivers from the MS store and in device driver it says that it is working properly, but it doesn't work. I have tried it on two PCs, both with Win 8 installed. Has anyone got it working on their machine,...
I was using PS3 controller in windows 8 using motionjoy , all of a sudden after few months my controller has stop being recognized , it is not charging & ps3 controller drivers are also no there in the device manager . Can someone please suggest me some way to solve this problem . It will be a...
Windows 8 PC controller in Drivers & Hardware
Hello, I have run into a problem with my Windows 8 computer once in a while, it's that my PC doesn't recognize USB ported devices as supposed to, but it does recognize things such as a wireless mouse and keyboard. Now, my question is, can I buy a wired Xbox 360 controller and connect it to my...
(Random) SAN CONTROLLER in Chillout Room
So im currently doing a project and im trying to design a SAN storage array. I have everything I need from rack - storage, but the guy im designing it with isn't happy with the controller's I find, "NOT enough FC ports, NOT it doesn't cluster, WAY too much money... etc" so my question is,...
Im wondering if its possible to use the gamepad to navigate, since to me it seems logical, and the xbox home button could work as a Win button so it would make perfect sense and 1 analog can be mouse, then shoulder buttons can be L or R buttons.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook