Windows 8 and 8.1 Forums

Acer-E1 572G Touchpad & Keyboard not working!

  1. #1

    Acer-E1 572G Touchpad & Keyboard not working!

    hi everyone
    a few days ago, i did a stupid thing ! :|
    the Synaptics touchpad driver was installed on my laptop (Acer-E1 572G - Win 8.1 - 64bit) and i installed Elantech touchpad driver without uninstalling last one!!!! :|
    so, touchpad and keyboard stop working any more!
    i did uninstall Synaptics but nothing changed! i did try to uninstall Elantech driver but did not find unistaller! so i did unistall it from device manager! but still nothing changed !

    i dont have restore point and i dont want change my windows !

    in device manager i got error code 19 for keyboard and error code 10 for touchpad!
    here is some screenshot:

    thank you
    and sorry for my english
    Last edited by Farzin5121; 10 Feb 2015 at 04:36.

      My System SpecsSystem Spec

  2. #2

    Welcome to the forums, go to control panel, uninstall "Launch Manager" in Programs, download from here and re-install it:
    Download Drivers and Manuals | Acer Official Site
    Try different drivers for synaptics, for example, Acer Aspire E1-572 Synaptics Touchpad Driver for Windows 8.1 64-bit Drivers download - Synaptics Software Update
    If you find ETD Ware in Programs, right click and uninstall it, that's your Elantech but I couldn't see it in your Device manager.
      My System SpecsSystem Spec

  3. #3

    thank you for your quick replay!!

    i did what you said;
    uninstalled Launch Manager from control panel and download it from that link you send and installed again! (but i think nothing happened there!)

    then download synaptics driver from that link you send and install it! it successfully installed but nothing changed again!
    in device manager i got that error still and touchpad and keyboard not working!

    i believe that Elantech driver is still there! :|
    and the problem is that!
    how can i uninstall that?!

    thanks again
      My System SpecsSystem Spec

  4. #4

    Check in programs whether you have ETD Ware (snip) installed, also try sfc /scannow command from the tutorial, run that command 3 times, if that doesn't help, run DISM command using the tutorial link below.
    SFC /SCANNOW Command - Run in Windows 8
    DISM - Fixing Component Store Corruption in Windows 8
    Click image for larger version
      My System SpecsSystem Spec

  5. #5

    ETDWare is not in my program list! when i try to install it i got failed

    I did also run sfc /scannow command 3 time and every time it said found cropped file and fixed them!
    I didn't try DISM command yet but i'm sure problem is ETD ! its installed but there is no sign of it and i cannot delete it :|

      My System SpecsSystem Spec

  6. #6

    Right click "PS2 Compatible Mouse" in Device manager ( one with the Yellow warning triangle) update the driver, don't try to install Elantech drivers.
    Take out the battery, disconnect the mains(remove the adapter), press power button for few seconds, leave it to rest for a while, then put the battery back and re-connect the mains and see whether it rectify the problem.
      My System SpecsSystem Spec

  7. #7

    finally problem solved

    That was what i exactly thought! the ETD was there !!!
    Fix that by flowing this tutorial (with some different!)
    Thank you brummyfan for your helps
      My System SpecsSystem Spec

  8. #8

    Glad you got it sorted and Thanks for letting us know
      My System SpecsSystem Spec

  9. #9

    Posts : 1
    Microsoft Windows 10

    Hi guys.i kinda have the same problome, half of my keyboard just stopped working like the keys.A,C,X and more i have windows 10 laptop:Acer-E1 572G. just like this guy .tried to find solution for days and feeling like i already did everything.the only thing i didn't try,was to update keyboard drivers. I visited any possible sit tryed in the offiacl acer sit and good apps too but not in even 1 was the option to update keyboard drivers only other stuff like audio,mouse....but never saw keyboard please halp):im sick of it already and i really need my computer back.thanks(;
      My System SpecsSystem Spec

Acer-E1 572G Touchpad & Keyboard not working!
Related Threads
Keyboard with touchpad for CAD in Drivers & Hardware
Hi All The changes to the MS OS'es and touch screens might bring some advantage for me and my CAD work if using keyboard and, if available, a touchpad(drawing board) in one. I work on a large screen attached to the laptop with a wireless KB. Has anyone of you used or come across anything like...
Hi My netbook is a Samsung n145plus and has 8.1 installed with all updates. (even if it's not officially supported but it works amazingly fine) I've installed the officia Samsung Elan touchpad driver as it seemed to work fine (it's for Win 7) except when scrolling with the edge of the pad...
A few days ago I formatted a drive and installed Win 8.1. Also installed all the drivers. Yesterday, when closing it downloaded some updates which it installed today. Now neither keyboard nor touchpad works. I connected a wireless keyboard but it won’t work either. Wired mouse does work. ...
Acer E1 510 touchpad issues in General Support
Hey team, This probably has been posted before lol. But, how on earth do you get the scrolling to work on this laptop? if it has the scrolling capability? Cheers
Hello everyone. I have one big problem. I reinstalled my 8.1 pro (legal copy, disk been fully formatted) and it was okay for few hours. Next time im starting the laptop, my keyboard and touchpad doesnt work. I plugged USB mouse and keyboard and it works just fine. I went to device manager and...
I have the keysonic ACK-340BT keyboard with touchpad and left-right buttons, i was using with an acer tablet and win 8. After upgrading to 8.1 the touchpad and buttons stopped working, rest of the keyboard works. tested on another 8.1 machine and same issue. So something changed from 8 to 8.1...
Hi, I recently bought myself a Windows 8 Laptop, to be exact it is a Toshiba c55t-a, and every time I type something my touchpad won't move like when I press the w key for example my cursor won't move when I try to. It get annoying when I'm playing games that I need to use the wasd keys and have...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook