Windows 8 and 8.1 Forums

Can't access my external HD after changing Permissions

  1. #1

    Posts : 3
    Windows 8 64

    Can't access my external HD after changing Permissions

    I changed the Permissions for my External Hard Drive (I am the Admin in this computer), I actually wanted to passport-protect it, and now Windows doesn’t let me change it back (my HD will not work in other computers either). Please help!

    First I tried system restore, that was useless, but then again I have never been able to fully complete successfully a system restore on this netbook, it always restores somewhat but gives me an error message.

    Then tried this Take Ownership Shortcut Option 3 “Add "Take Ownership" with Pause to Context Menu” The “take ownership” option appeared successfully, when I took ownership of the folders a long list of messages saying that is was successful appeared, but when I did this on the Drive, the black dialog box opens and closes so quick that I can’t see any message on it, if there is any, so I can’t see if it was successful.

    Creator Owner appeared on list after doing this, but the only Alowed box ticked was “Special Permissions” everything else was unticked with neither Allowed nor Denied.

    User Everyone has List folder contents as Allowed and Write as Denied, everything else unticked.

    User SYSTEM has everything ticked as Allowed except for Special Permissions.

    And there is a 4th user with a very long number as a name and a question mark on the person of the icon, which has the same Special Permissions as the Creator Owner (this was there before Taking Ownership.

    Before taking ownership I was able to delete files, but not copy or modify them (documents appear as read-only files). Now I’m able to both delete and copy files to another location (clicking on providing admin permission when prompted) but I cannot write any new information or copy files to the HD (no pop-up asking to give admin permission here). So at least I can access my files now, but still my Disk is useless as a back-up.

    Again, the Edit button on Security doesn’t allow me to change anything, I can’t tick or untick any boxes, and the Advanced button is just the same: when I click on Change Permission another dialog just the same appears where I can only click View, Ok or Cancel. The Add, Remove and Apply buttons appear greyed-out. The funny thing is that Creator Owner appears as having full control of Subfolders and Files only, so in theory I should be able to write over files.

    Thirdly, I have tried finding the “Access Control Settings for Local Disk dialog box” but I’m using Windows 8 and I’m afraid this just isn’t an option there.

    What else can I try?
    Attached Thumbnails Attached Thumbnails print screen.jpg  

      My System SpecsSystem Spec

  2. #2

    Posts : 2,690
    Windows 3.1 > Windows 10

    That topic was from 2009 and was for windows 7
      My System SpecsSystem Spec

  3. #3

    Posts : 3
    Windows 8 64

    I was finally able to see the Comand Prompt screen after trying to take ownership of the drive (by taking a print screen just on time) and in fact there is an error message: ERROR: File or Directory not found.

    Any suggestions as to what else I can try or why this is not working?
      My System SpecsSystem Spec

  4. #4

    Posts : 3
    Windows 8 64

    I tried several more things from a few posts, including External HD permissions - how to get rid or easy way to se & the icacls "full path of folder or drive" /grant "user name or group":F /T command on the Comand prompt and they all gave error messages.

    Finally, what worked for me was the command takeown /f [root dir of drive] /r /d y it took over an hour to go through all the files, but did so successfully
    and after that I was able to tick the Full control box for Everyone.

    So I guess password-protect, and not changing permissions, is the way to go. I'm a bit wary of trying anything again after this mess though. Win8 cannot be trusted.
      My System SpecsSystem Spec

Can't access my external HD after changing Permissions
Related Threads
How to Allow or Deny Access Permissions to Users and Groups in Windows 8 and 8.1 This will show you how to add, remove, allow, and deny users and groups access with "basic" and "advanced" permission settings of a file, folder, drive, or registry key in Windows 8. When you set permissions of...
Heres the deal, i had windows 7 laptop with all my things it worked great until it got wet. The HDD was in perfect condition, I took it out the HDD and started using it on my ubuntu computer, (via sata to usb adapter) i had 2 partitions on this drive, /C with windows and all my important documents...
I'm having trouble with the environment configuration on my new Win8 machine, I don't remember running into problems like this on 7, but I can't seem to find much useful online.. I have 4 dll files that need to go into the Windows\System32 folder in order for one of our applications to run. This...
Hi, I just bought a new laptop with windows 8 for wife. On my old laptop I have windows 8 too. I have 2 TB HD connected to my Old laptop which contain almost all of my Media files etc. Now I wanted to pass some stuff to my wife so I connected the External drive to the new laptop but to my...
So sick of the patronisation of recent Windows releases. I am currently on 8.1. I can't figure out what else I have to do, to save a config file to the root of C. It's an old application, and that's where the config needs to go. I am worried that the medicine is worse than the illness in this...
Manage Permission Inheritance in Windows 8 | VISHY Media on technologies and gadgets 3882 Ever get this message or worse, one that does not have the access button attached? you cannot read it, you cannot look at it and you cannot delete it. There are even worse issues where the...
Permissions: Access denied in BSOD Crashes and Debugging
"The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID {9BA05972-F6A8-11CF-A442-00A0C90A8F39}" (This is the SHELL) Multiple errors in Event Viewer. When I try to rectify this using Component Services>D COM, all options are...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook