Windows 8 and 8.1 Forums

Surface Pro - Marvell Avastar 350N controll stops working

  1. #1

    Posts : 9
    Win 8.1 pro

    Surface Pro - Marvell Avastar Controller stops working

    Surface Pro acquired April 2014, has Marvell Avastar Wireless network 350N controller- driver V14.69.24054.176, which appears to be latest version when I checked it. For the past three months or so the controller fails to connect several times each month. All failures appear to be random and not related to a particular day or period of days, and is evident at startup as no internet connection is made. A call to MS last fall, when it first occurred, got only the suggestion to use Device Manager to uninstall the controller and restart. That works each time until the next failure. I reported this to the Surface forum and was unable to solve the problem by looking at logs, etc. This is very annoying and is certainly not necessary. I want to get this fixed while still under warranty in case the Surface needs replacing. Your help appreciated. Roving
    Last edited by roving; 14 Jan 2015 at 16:19. Reason: spelling error

      My System SpecsSystem Spec

Surface Pro - Marvell Avastar 350N controll stops working
Related Threads
Read more: Microsoft stops producing the Windows RT-based Surface 2
Solved Taskbar stops working in General Support
New Windows 8.1 laptop, one week old, no malware of any kind, working perfectly fine until just a few minutes ago. I have the taskbar customized with shortcuts that I use all the time. Suddenly, clicking one of them does nothing. Whether it's a browser or Notepad or whatever, it simply does not...
Windows stops working. in BSOD Crashes and Debugging
Randomly (or at least I cannot find consistency) Windows will stop working. It will ask me to force stop but I cannot click it because it is frozen. Any open programs will work, if I try to open task manager it wont, and when I Ctrl+Alt+Delete and go to restart it completely freezes up. The last...
I have WIN 8.1 installed on a Gateway DX 4822IE 10 and now IE 11 continually stop working,can find no fix on MS web site, any ideas on this????
I am running Windows 8 x64 on an Intel DX48BT2 motherboard. The Network adapter is a built-in INtel 82566DC-2. Simply put, WOL works fine as long as I don't let the computer sit in sleep mode for too long. However, if I let it, for example, sit overnight, then it cannot be woken with a magic...
Hi there for some reason I can't read pdf documents any more with Adobe reader XI. Windows 8 x-64. The application just hangs --tried this on TWO different computers. Tried also different documents too. Comes up with "Failed to connect to DDE server" whatever that is. Screen shot enclosed. ...
Hello, I have a Tablet PC with Windows 8 Release Preview installed. The Tablet PC is equipped with a x86 Intel Atom Z670 processor and the Marvell 88w8787 Wifi/Bluetooth chip. (Also ref. as AZUREWAVE_AW-NM387 WiFi/Bluetooth) Previously, Windows 7 installed with wifi connection was working...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook