I've connected an ESATA Samsung Story station (HD154UI) to port 3_2 on the controller using the enclosed bracket. The drive has an external PS. When booting the PC this HD device only shows up occationally and I have to press ctrl+i to access the Intel RAID utility. Sometimes the device will then show up and is accessable when Windows is loaded but only occasionally. Sometimes the drive is accessable in Windows Explorer anyway but in most cases I have to reboot. And sometimes the connection even fails while the PC is running. I've installed a patch from Samsung (i.e. Seagate now) support but that didn't solve anything. The drive worked without any problems in my previous rig using Win 7 Ultimate 64-bit. Asrock support tells me that the Samsung drive is not supported under Win 8.1 but the Microsoft compatibility check states that it is. I'v tried using another ESATA cabel but the problem persists.

Four HDDs are connected to ports 3_0, 3_1, 3_4 and 3_5 configured as RAID 5. The SSD system disk is
connected to port 3_3. My two BlueRay drives are connected to the ports 3_A0 and 3_A1.

I can see from the list of connections that is automatically generated when posting a case to Asrock support that the SATA port 4 is labeled SATAEP_1/SATA_4 while the others are labeled 3_0, 3_1 and so on but I as far as I can see from the manual an ESATA drive can be connected to any of the SATA ports.

I've updated UEFI BIOS to the latest version (1.3) and all drivers are updated using Asrock's update utility.

Anybody out there got an idea?