Windows 8 and 8.1 Forums

External disk : diskpart shows disk but no drive letter

  1. #1

    Posts : 4
    windows 8.1

    External disk : diskpart shows disk but no drive letter


    I have a HDD 750G with 2 partitions NTFS with data.
    used externally in a USB3 box connected to my windows 8.1 asus laptop.

    No idea what I do, I always use 'eject' before disconnecting this HDD, but now I see that with diskpart :

    DISKPART> list disk

    Disk ### Status Size Free Dyn Gpt
    -------- ------------- ------- ------- --- ---
    Disk 0 Online 238 GB 1024 KB *
    Disk 1 Online 22 GB 0 B *
    * Disk 2 Online 698 GB 611 GB

    DISKPART> list volume

    Volume ### Ltr Label Fs Type Size Status Info
    ---------- --- ----------- ----- ---------- ------- --------- --------
    Volume 0 E DVD-ROM 0 B No Media
    Volume 1 C OS NTFS Partition 49 GB Healthy Boot
    Volume 2 D Data NTFS Partition 167 GB Healthy
    Volume 3 SYSTEM FAT32 Partition 100 MB Healthy System
    Volume 4 Recovery NTFS Partition 900 MB Healthy Hidden
    Volume 5 Restore NTFS Partition 20 GB Healthy Hidden

    so disk 2 is there, but no volume, no partition, no drive letter. just a 'bip' sound when I connect the disk to usb port.

    i try with paragon disk manager or aomei partition assistant, but can't assign a drive letter (option greyed)
    how can I do to get 2 drive letters & access my datas ?

    thanks for help

      My System SpecsSystem Spec

  2. #2

    What does Win8 Disk Management show for that drive? If it shows as "raw" in the list, and it won't let you assign a drive letter, it could be that the drive has failed.
      My System SpecsSystem Spec

  3. #3

    try in diskpart
    select disk 2

    See if that gives a drive letter to one of the partitions on the drive, if not, afraid you got an error in the mbr or gpt tables. Or as said, drive has failed..............
      My System SpecsSystem Spec

  4. #4

    Posts : 4
    windows 8.1

    thanks for help, but still not solved (diskpart - assign don't assign a letter).
    in attach the disk management screenshot (disk 3 here)
    Click image for larger version
      My System SpecsSystem Spec

  5. #5

    So basically, it won't let you assign a letter to the 88GB OEM partition on disk #3?

    What you could try is using the Minitool Partition Wizard Free Edition to do a Check on that partition. That will force a CHKDSK to be run to see if the filesystem is corrupted.

    After that, you should be able to assign a drive letter.
      My System SpecsSystem Spec

  6. #6

    Posts : 4
    windows 8.1

    I try ESAUS partition recovery & active partition recovery, but can't get my data back
    a delete partion / create partition solve the issue
    Thanks for help
      My System SpecsSystem Spec

  7. #7

    Deleting and recreating partitions does not actually erase the files and folders, it just recreates the partition table.

    You might still be able to recover some of the files and folders using "recuva".
      My System SpecsSystem Spec

  8. #8

    I don't understand how you managed to end up with a 'logical drive' instead of a primary partition, either mbr or gpt. sounds like you have a boot record error, the drive type got changed somehow. If you re-initialize the drive you'll lose any info on it. I used to use aefdisk32 on xp to manipulate the partition type descriptor on computers with virus changed mbr's. I've never had to change one with diskpart, but deleting and re-creating a partiton WILL remove formatting, and files WILL be lost from the directory structure. A logical drive was only used with MBR partition structure when more than 4 partitions were needed. It isn't used in GPT, as the partition table isn't limited to 4 partitions.
      My System SpecsSystem Spec

External disk : diskpart shows disk but no drive letter
Related Threads
Hi, I have an external 1TB-USB-HD, which is shown in the WIN adminstration of drives, but the option "assign drive letter" is grey. I use this drive since a year, formerly it was recognized without problems. The device manager recognizes it, the driver is actual. The PC further has one internal...
I have found the solution, it is standardly unmounted (but i made it mount with ''partition found and mount, but now im dependable on that program for the hard drive to be mounted, so how do i make it like a normal hard drive?? and how do i format it so that its like a normal hard drive)now so the...
my ssd broke so i went got a new one today i do a fresh install of win 8 but its showing up as removable disk my pc specs-sabertooth fx990 r2.0 mb win 8
Hello Everyone, Over the last couple days, I built a new PC and installed windows 8.1. Initially I had some issues installing windows, so I unplugged all my drives except the SSD and DVD. I installed windows to my SSD. Everything works great! Now I started adding my drives back in 1 at a...
My USB disc comes up with the letter 'J'. Because I have references to it with a letter 'X'. I want to change it and I do that in the Computer Management tool with the Disk Management utility. Computer - Right click - Computer Management Disk Manegement - Right-click the drive and then click...
Hey all, I recently upgraded from Windows 7 to Windows 8 and I'm loving it, EXCEPT for this one problem I'm having. Immediately after I upgraded, my external hard drive (WD Ext HDD 1021 3TB) was missing from "My Computer." I never had any problems with this HDD before I upgraded, and the...
I have a hard disc on (B:) and when I got to my computer it does not show it but if I go to manage it shows it. On windows 7 it works fine it does not have windows 7 or 8 on it and is classic hdd not ssd. It will show anything that has a letter from c and above it shows my other 3 hard disks. Any...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook