Windows 8 and 8.1 Forums


Intel Management Engine Interface Problem

  1. #1


    Greece
    Posts : 341
    Win8.1 64bit, Windows 10 TP on VMWare Player

    Intel Management Engine Interface Problem


    In Device Manager I have an ! against Intel Management Engine Interface.

    In Driver Properties it says:

    This device cannot start. (Code 10)
    An invalid parameter was passed to a service or function.

    I have also seen errors related to this in a recent Perfmon report.

    I have tried to update the driver (right click on it in Device Manager, check on Dell website, check with Intel Driver Update Utility) but all these methods say I have the up to date one.

    On my other Dell laptop (same spec) the same version of this is running without a problem. On that laptop there was an update in mid November that I don't have on the problem laptop. I have a feeling that I did a System Restore back around that time that affected a few things, and this may have been one of them. I thought I had kept a screenshot of this, but must have deleted it so I can't be sure.

    Question is: how can I get this working again?

    Should I try uninstalling and reinstalling it?

    If so, what is the best (and most foolproof) way to do this? Can I do it from the right click options in Device Manager, for example? I'm a bit concerned that, if I uninstall it I may not get the correct version back again.

      My System SpecsSystem Spec

  2. #2


    Posts : 2,690
    Windows 3.1 > Windows 10


    yes uninstall the driver until you get the ? mark for unknown device, reboot and reinstall the driver
      My System SpecsSystem Spec

  3. #3


    Greece
    Posts : 341
    Win8.1 64bit, Windows 10 TP on VMWare Player


    Quote Originally Posted by KYHI View Post
    yes uninstall the driver until you get the ? mark for unknown device, reboot and reinstall the driver
    Thanks for this, KYHI.

    As I'm not very technical can I just clarify:
    • will I get the ? for unknown device as part of the process of uninstalling using the right click?
    • and from where do I reinstall the driver?


    I prefer to know what I'm going to encounter before I start down an unfamiliar road whenever possible .
      My System SpecsSystem Spec

  4. #4


    Posts : 2,690
    Windows 3.1 > Windows 10


    properties - uninstall driver
    download dell driver (extract) then click unknown device - update driver - browse - point to extracted dell driver ( this will load the driver only) not the app.. if you want the whole app - run the dell driver setup
      My System SpecsSystem Spec

  5. #5


    Greece
    Posts : 341
    Win8.1 64bit, Windows 10 TP on VMWare Player


    Quote Originally Posted by KYHI View Post
    properties - uninstall driver
    download dell driver (extract) then click unknown device - update driver - browse - point to extracted dell driver ( this will load the driver only) not the app.. if you want the whole app - run the dell driver setup
    Thanks for the clarification KYHI. Will have a go at this in the next few days and see if it does the trick.
      My System SpecsSystem Spec

  6. #6


    Greece
    Posts : 341
    Win8.1 64bit, Windows 10 TP on VMWare Player


    Quote Originally Posted by KYHI View Post
    properties - uninstall driver
    download dell driver (extract) then click unknown device - update driver - browse - point to extracted dell driver ( this will load the driver only) not the app.. if you want the whole app - run the dell driver setup
    Just uninstalled, which was slightly disconcerting as it installed the device as well as the driver.

    Rebooted and reinstalled and now I have a properly working driver again .

    Another one to tick off the list.

    Thank you KYHI
      My System SpecsSystem Spec

Intel Management Engine Interface Problem
Related Threads
Are these 2 drivers system-specific, or can I bypass the OEM's outdated drivers and grab the latest versions straight from Intel?
I have been going crazy try to update my ASUS H81M-PLUS motherboard BIOS. ASUS is no help. Intel is no help. This might not be the right forum for this, but, I reached a point in the BIOS update (complicated) process where it now wants me to download the following driver for an Intel 4gen...
I seem to be in a loop while upgrading from a Pentium G840 to an i3770 K on an Intel DH61WW motherboard. It seems that I need version 8.x of Intel Management Firmware and I can't get to update past version 7.1.52.1176 According to this page, I need version 8.x to continue for updates to use...
I just bought this new Asus VivoTab Smart. The MS Windows Explorer works fine, it was already on the Start screen. I added 2 ordinary Google search engines, (one in the UK) to the Start screen. (Neither was a Google Chrome). When I try to use either one of them I get this message: "There is a...
Hello eightforum users, i Got an really big problem.. i just reinstalled my PC, obviously with windows 8. and i cant seem to play games, i mostly play COD4 and whenevery i join a game, i get an Dirextx error, or my PC just reboots.. i dont know if it has something to do with my LPC INTERFACE...
A Review of Intel Will Windows 8 evolve further that just touch?
Hello, I am trying to install the Intel MEI (Intel Management Engine) for the Asus P9x79 WS motherboard. I have had no issues installing this on Win7 x64. However, when trying to install the drivers in Win 8 x64 from the Asus install CD, I get a OS not supported message. There are no drivers...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook