Hello and thank you for your help,

(I am sorry if I added too much info, I'm not very tech savvy so I didn't want to leave anything relevant out. I have a TLDR at the bottom so you can skim the body if you like.)

My system is an Acer Aspire V5 laptop with 8gb RAM, 500gb harddrive, i5 processor and 2x USB 2.0 hubs and 1x USB 3.0 hub. I am running Windows 8.1.

Yesterday I attempted to use a different mouse from usual (Logitech G500) and then the dialogue box came up to install the drivers for the mouse. After it closed, I could not use the mouse, and when I looked further, "G500" was under Other Devices. Under properties it said "The drivers for this device are not installed. (Code 28)". When I pressed "Update Drivers", every time it would fail to find the drivers.

This problem did not effect my old keyboard.

I tried unplugging/replugging the mouse, using a different mouse (very generic, on other computers it registers as 'HID Compliant mouse) and different USB ports to no effect. The Hardware and Sound troubleshooter in the control panel also did not help, and it prompted me to install the drivers for the devices over and over again.

After researching the problem for a while, I came across this article. It seemed relevant, so I followed the steps to delete all of the devices under the "Universal Serial Bus Controller" node, so that windows can reinstall all of the necessary drivers. This included 3 USB controller devices, my processor and other things.

I restarted, and although everything else seems to be working, my USB hubs do not register any devices including the old ones that worked before (no lights in my keyboard or system chimes when I plugged stuff in).

The Universal Serial Bus Controller devices are now under the "Other Devices" thing in the device manager. I seem to have royally screwed up, because Windows didn't reinstall the drivers for it. They have the same error code as the mice had before (error 28), and the same problem with not being able to find drivers.

TLDR: Mice showed Error 28 in Devices manager and the drivers could not be found by windows. Stupidly I uninstalled all USB controller devices including the USB hubs, and now I can't do anything with them.

Thank you very much for reading and thank you for your help.