Windows 8 and 8.1 Forums

USB keyboard not working (usb not detecting)

  1. #1

    Posts : 1
    Windows 8

    USB keyboard not working (usb not detecting)

    So i've been tearing my hair out with this problem for the past few weeks, and i've come here for help. Im using an Azio Levetron Mech5 keyboard that i got about a month or so ago, and since an update, it hasn't been detected by my computer unless i take out my laptop battery and start up (and even then, it works only for 5 minutes before blanking out). Open to suggestions, Thank you so much!
    Last edited by mesaif; 23 Nov 2014 at 19:55. Reason: Spelling

      My System SpecsSystem Spec

  2. #2

    Forever West
    Posts : 591
    WinVista, Win7, Win8.1, Win10, Mac OS X 10.10, Linux Mint 17.1

    Is there a reason for an External keyboard [USB?] on your Notebook/Laptop such as the built-in keyboard doesn't work? Most times simply plugging in a USB keyboard works in addition to the built-in keyboard. Same for a mouse and touchpad but the touchpad can be disabled.
      My System SpecsSystem Spec

  3. #3

    Posts : 44
    Windows 8.1 Pro x64

    1. Remove Update / Reinstall drivers.
    2. Try another keyboard to see if that works?
      My System SpecsSystem Spec

  4. #4

    Queens, NYC, NY, USA
    Posts : 11
    Dual-Boot Windows 8 (upgrading to 8.1 soon) & Kali Linux (formerly Backtrack)

    I've had this happen before, and it turned out to be a USB 2.0/3.0 issue. Here are some things to try:

    • Check batteries. Replace even if you think they are good.
    • Make sure your laptop has the correct USB drivers in, and, as suggested by EVIL NEMESIS, update/reinstall USB drivers.
      • NOTE: In the CHIPSET section of the drivers page for your laptop, there may be a SEPARATE USB 2.0/3.0 driver, in addition to the standard chipset drivers.

    • Go into your BIOS and make sure USB mode is set to LEGACY, if available.
    • Is the keyboard USB 3.0? If so, are your drivers current on your laptop?
    • Does it have a connect button on your keyboard?
      • If so, turn off keyboard (if a switch exists), then turn it back on.
      • Press and hold the connect button for 3 - 5 seconds.
      • Let go, and try.
      • Repeat a couple times.

    • Remove ALL USB devices, restart computer, connect ONLY the keyboard.

      My System SpecsSystem Spec

USB keyboard not working (usb not detecting)
Related Threads
Hi, I updated my Synapse software (Razer) and suddenly my BlackWidow mechanical keyboard isn't working fully. The F keys are not working correctly the F10 mutes and F11/12 turn the volume up and down (almost like it's a laptop keyboard). The Windows key has swapped with the ALT key and also the...
Laptop Keyboard Not Working in Drivers & Hardware
Today i turned on my G73JH today and my keyboard is not working, I have windows 8.1 and had to use the on screen keyboard to type anything in. The keyboard works fine when i press F2 to go into the bios and and can navigate around the bios no problem. Anyone else having this problem?.
Solved Keyboard not working properly in Drivers & Hardware
My keyboard has been performing unusually. I don't do anything do activate this, but all of a sudden I can't type anymore and if I press D, for example, it goes to desktop and if I press K, a menu pops out from the right side of the screen. I checked if somehow Sticky Keys or Filter Keys had...
Solved Keyboard not working in General Support
Hello, I have cleaned my new laptop yesturday - bought it before 1 month and now the "0" on the right side of the keyboard is not working at all. If I click 0 I get a menu like if I clicked the right click on my mouse. Also the touch pad is not working at all. All that happened...
Same problem here stuck on the lock screen, no choice but to power down and reboot. Dell XPS420 with Logitech wireless mouse and Dell USB keyboard ... 8.1 preview doesn't recognize either device
Solved Pc keyboard not working properly in Drivers & Hardware
I have a pretty good keyboard at my pc and i am sure that nothing rong with it but some times it just stop working, and the all the lights turn off with no warning, after that, about 1-2 min the keyboard just keeps pressing up to 10 sec the key i press... i have no idea why
Since installing Windows 8 my ASUS EEE 904 HA function keys are disabled. Also typing anything is a challenge as the characters I try to type go haywire. I would like to upgrade to Windows 8 but I'm burned out having not found a fix. Where can I get help or should I just uninstall it? :cry:
Eight Forums Android App Eight Forums IOS App Follow us on Facebook