Windows 8 and 8.1 Forums


Adding Extra HDD and MBR Error, Then 8.1 Doesn't Load

  1. #1


    Posts : 7
    7 Pro

    Adding Extra HDD and MBR Error, Then 8.1 Doesn't Load


    ok, here's what i've done.

    installed & set up 8.1 on a new HDD

    shut down, reconnected my old HDD with win7 installed

    rebooted and win 7 loaded without any option on what to boot from

    i copied most of my data files from the win 7 HDD to the 8.1 HDD

    disconnected the win 7 HDD and connected up a different HDD that had some other files stored on it.

    rebooted and i then got an MBR error, saying there wasn't one, tried putting in the dvd to repair it, says it couldn't repair

    i opened up the PC, disconnected the spare HDD

    restarted and 8.1 loads as per the original install and working fine.


    Question is,
    how can i get this HDD to be recognised by 8.1 after when it's connected up, 8.1 gets an MBR error and can't load?




    thanks for any info on this

      My System SpecsSystem Spec

  2. #2


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    You need to change the boot priority in the BIOS ie. set the Windows 8.1 to be the first boot device.
      My System SpecsSystem Spec

  3. #3


    Posts : 7
    7 Pro


    hi,

    thanks for the reply, my problem is, when using 8.1, no other HDD is getting recognised.

    like, when i attached a sata HDD with a USB cable to a USB port, nothing is recognised, even in disk management.
      My System SpecsSystem Spec

  4. #4


    Maryland USA
    Posts : 758
    Windows 8 & Windows 7 Dual Boot


    Try assigning it a drive letter in windows 8.1
    Right click COMPUTER and select MANAGE
    Find the harddrive with a missing drive letter and is of the capacity you know it is.
    Then select add or assign a drive letter, and select your own for easy finding or let windows preselect it.
      My System SpecsSystem Spec

  5. #5


    Posts : 7
    7 Pro


    Hi,

    as i've mentioned, it's not seen in disk management to assign it a drive letter
      My System SpecsSystem Spec

  6. #6


    Maryland USA
    Posts : 758
    Windows 8 & Windows 7 Dual Boot


    Lets try a partioning program to see what windows cannot..

    Download aomei partition assistant

    If the other harddrive is not seen by this program, then you need to check your SATA power or data cable, use different ones if you have them, and make sure they are snug..

    Try them in different ports on your motherboard
      My System SpecsSystem Spec

  7. #7


    Posts : 7
    7 Pro


    hi,

    thanks for your reply, i'll try that when i get home from work in a couple of weeks
      My System SpecsSystem Spec

Adding Extra HDD and MBR Error, Then 8.1 Doesn't Load
Related Threads
Weird issue, I've tried to research it and found nothing so here goes. The internet is fine I play games on it and everything, but I cannot load web pages correctly. *windows 8 btw* A youtube video will open up then play for about 5 seconds then stop completely. Some pages get SSL errors, then when...
Hello, I updated my PC to 8.1 pro only because I been reading they wont be offering assistance to 8 users and free upgrades soon so I took the leap. Now my PC runs fine on 8.1 except it does something to Chrome. Ever since I updated my Chrome takes forever to load a tab OR if I open a website I...
Hey i have added music(.mp3s) or sound effects on my videos no problem on Movie maker.. But i am having a bit of a problem now it keeps on saying ''error adding Music starts after the last(photo or video)'' in project. i have tried it and it still won't work doing. And i was putting...
Hi. So I've got a problem with RAM. I have 4 DDR2 slots (2 yellow and 2 black ones) on my old Asus P5PL2-E mainboard. I've been only using the yellow ones until today with 2x1Gb Samsung 533Mhz RAM modules. Today I bought another pair of Samsung RAM, same size, but they're working on 800Mhz. I put...
I have a dual boot system with Win 7 and a Win 8.1 and all works well. I am using two SSD's with Win 8 and the other with Win 7. Asus Maximus v Gene, i5 3570k and 16 gb ram. When I boot into Win 7 with an additional internal hdd plugged into a mob SATA port all is ok. However, when I attempt to...
I have a 2 month old Dell Inspiron 660 running Windows 8.1.that came with windows 8 installed but I upgraded to 8.1 off the internet. Everything worked okay until I did a scan and cleaning with ccleaner. Pretty soon startup was very slow going from the Dell screen to the lock screen to the...
Hi All, Getting a strange error with Hyper-V on Windows 8 Pro x64. When I try and add a virtual switch I get: Error Applying Virtual Switch Properties Changes Failed while adding virtual Ethernet switch connections. Ethernet port '{a bunch of stuff}' bind failed: The data is invalid....
Eight Forums Android App Eight Forums IOS App Follow us on Facebook