Windows 8 and 8.1 Forums

"Please Insert Disc" prompt when there is a DVD in drive

  1. #1

    FIXED:"Please Insert Disc" prompt when DVD is in drive

    SOLUTION: Windows 8.1 repair install from original media.

    I keep getting this error:

    Click image for larger version

    When I try to click on a dvd drive, which has a DVD inside.

    It doesn't matter which of my DVD drives nor which DVD disc is used.

    So, Windows doesn't recognize the DVDs (or CDS or Blu-Rays) inside the drives.

    Does anybody have any ideas as to what might be causing this?

    My system is Windows 8.1 Pro x64 with all updates. Drives are both SATA and PATA drives.
    Last edited by halcyon; 07 Nov 2014 at 12:41.

      My System SpecsSystem Spec

  2. #2

    Possible bad machines but just in case it's because of the drivers' go to Device manager, find drives and uninstall them, reboot and proper drivers should be installed.
      My System SpecsSystem Spec

  3. #3

    Thank you for your input.

    I tried this (Device Manager / Uninstall / OK / Reboot) as Administrator:

    Click image for larger version

    However, this did not cure the problem.

    All the drives are 100% functioning (6 of them), they are not broken.

    They are on 2 separate controllers and the controllers are also working fine (discs can be read / written to 100% ok).

    Only I can't browse the discs contents in Windows File Explorer, as Windows keeps ejecting the drive trays and asking me to insert a disc.
      My System SpecsSystem Spec

  4. #4

    Posts : 683
    Win 8.1.1 Pro x64
      My System SpecsSystem Spec

  5. #5

    Thanks TairikuOkami. I tried all those.

    Still the same problem
      My System SpecsSystem Spec

  6. #6

    Posts : 689
    Windows 8.1 Pro with Media Center

    Ironically I've been having weird DVD drive issues as well although mine has been disappearing or delaying. I also have a Lite-on writer as well. Anyway it's weird because I've never had issues before in the past so I wound up replacing that drive with a new one - still Lite-On.

    During the replacement I discovered one of my extension cables connecting to the power cable to the drive had a loose wire. So check your connections.

    Anyway I was still having issues, maybe because the loose wires hosed the driver install, so I wound up doing a Repair Install Windows 8. Luckily I do have a physical disk so that worked out fine for me. For now all seems to be good but...

    One other thing I did do as well... check Lite-On's site and see if there's a firmware update for your drive. If so, give it a try. My old drive did have a firmware update that I applied, but at that time I saw no improvement; however, this was before I discovered the loose wire. But check here: Software Tools > Utilities and look for SmartPack - Firmware Auto Upgrade.

    Thus my suggestions are...

    - Check for loose wires
    - Check for firmware update
    - Try a repair install
    - Replace drive

    Looking back now I don't think my old drive needed to be replaced. This is why I listed replace last.

    Good luck.
      My System SpecsSystem Spec

  7. #7

    Thanks. I have six drives. On two separate logical controllers, using four different cables.I

    I've rechecked them all.

    Yet, the problem persists.

    However, the drives are working 100% fine. I just can't browse the contents of the discs from File Explorer.
      My System SpecsSystem Spec

  8. #8

    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit

    Just for the sake of ensuring system files are good have you run sfc /scannow?

    If good then may take a refresh or repair install as already suggested. No restore point or backup image before this started?
      My System SpecsSystem Spec

  9. #9


    Thanks for the suggestion.

    Yes, I Have run sfc /scannow in an administrator command prompt. No problems were found.
      My System SpecsSystem Spec

  10. #10

    I just installed a brand new BD-RE drive (SATA) and it exhibits the exact same issues:

    1) Drive burns 100% ok (disc verify and scan perfect)
    2) Drive reads data 100% ok (I can read data using an additional software, just not in file explorer)
    3) I can NOT browse the contents of any disc from windows file explorer
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
"Please Insert Disc" prompt when there is a DVD in drive
Related Threads
Add "Lock Drive" to Unlocked BitLocker Drives Context Menu in Windows 7 and Windows 8 To lock an unlocked fixed data drive (ex: internal hard drive) encrypted by BitLocker, you would normally restart the computer. To lock an unlocked removable data drive (ex: USB drive) encrypted by...
Hi All, I want to format my external hard drive into two partitions so that I can use one of them as a recovery drive for my Windows PC and the other one for my personal data. I am using Windows 8.1. It is a 1TB WD Elements hard drive currently formatted into one exFAT partition. It is about...
Hi all, So I'm kind of stuck.. I currently have the problem where I am in an endless cycle of "loading files" -> "Windows Boot Manager" (see: How To Boot Into Safe Mode On Windows 8 (The Easy Way)). I have tried to load all of the options -- and none successfully load. I also end up at...
Hi.I am using Windows 8.1 Pro.I turned on bitlocker on one of my drives to secure it.i used fast method.after the encryption process the drive became inaccessible and giving access is denied messages.I tried to turned of the bitlocker but i cant because it just vanished.i cant find it anywhere on...
Windows 8.1 "Upgrade" disc in Installation & Setup
I was wondering if they made a Windows 8/8.1 upgrade disc available yet? Would like to put this up on my tower someday, if the cost isn't prohibitively high and the requirements are much lower. I actually have a board that supports SecureBoot.
What's the "Search" command prompt in Win8 pls? I thank you.
Hi all once you've got an ISO file on Disc you can mount it with a right mouse click on the file. You can then use any standard software you like to access the DVD for example I'm playing a DVD (Battlestar Galactica 1980) with VLC (can't find a replacement for W7 snipping tool but old...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook