Windows 8 and 8.1 Forums


Printer USB malfunctioning (Error 43) - is it restorable?

  1. #1


    Posts : 9
    Windows 8.1

    Printer USB malfunctioning (Error 43) - is it restorable?


    I recently bought a Canon PIXMA iP2850 printer and was trying to install it today, however I made the mistake of trying to download the relevant software from online BEFORE actually plugging in the printer to my computer. I believe that this caused an error when plugging in the printer resulting in it deleting all the software.

    This theory could be incorrect, but I am now in a situation where my computer will not recognise the printer and it comes up with an error sign saying the USB malfuctioned and that the 'Device Descriptor Request Failed'. It's possbile that the printer was faulty beforehand.

    On Event Viewer (which I could theoretically upload if required) it shows that 17 seconds after being first plugged into my computer 'Device USB\VID_0000&PID_0002\5&CB243C1&0&2 was deleted.'

    Is there any way to undo this? Is this at the heart of the problem or am I incorrect? Is there anything I can do to get my printer working?

    Thanks for any help- I'm stumped by all of this.

      My System SpecsSystem Spec

  2. #2


    With the printer disconnected from the computer, go to Control Panel > Programs and Features, and uninstall all dealing with the Canon. Check Device Manager and uninstall any driver there for the Canon. Reboot, then start over following the instructions in the user manual.
      My System SpecsSystem Spec

Printer USB malfunctioning (Error 43) - is it restorable?
Related Threads
Okay, so I got an error message a while ago stating that "Power Surge On Hub Port: A USB device has exceeded the power limits of its hub port", I ignored this message for a while until my USB, wireless mouse receiver stopped working completely (BTW at this point I had a WiFi adapter, Bluetooth...
Hello! Recently I've come across an issue with my Toshiba laptop (Windows 8) and I am completely puzzled as to what this issue is. When I open my primary account, my mouse will work for around a minute, allowing me to open programs etc. But then it will stop. Just stop working, in one set area....
I have a Epson XP-405 and it worked well on my first computer, with windows 7. Now I have a new computer with windows 8.1, i downloaded the newest version of the driver for my printer but by the installation it says "the printer driver software can not be installed". I have removed the printer...
network printer issue error code in Network & Sharing
I"m trying to access the printer which is on a network on a windows 7 computer but when i click on my network and click the computer's name on my windows 8 64 bit laptop I get error code 0x80070035 I have check my kaspersky firewall I also allowed all epson software through. I have disabled the...
Just updated my window 8 to window 8.1 last few months and getting trouble with my little printer. Problem: Driver need troubleshooting (unavailable) but i already install? 1)having problem when install the driver from HP support and downloaded the correct driver which is window 8.1 64bit...
My desktop app is not functioning correctly. The tile has vanished from the start menu and search, the shortcut button in my program data is still there, but does not work, and it does not show up as an app in the side bar thingy, it was fine yesterday and nothing has changed since then, it...
Help with Printer Error in Drivers & Hardware
I have a Brother HL-2170W printer and I do not have the CD for it, as it was given tome by someone. I have installed the hardware, and tried to print a page, and I get an error. All it says is Print-Error. Please help! Thanks in advance.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook