Windows 8 and 8.1 Forums

USB 3.0 flash drive not recognized in one PCs USB3.0 ports

  1. #1

    Posts : 1
    Windows 8.1

    USB 3.0 flash drive not recognized in one PCs USB3.0 ports

    Hello, I have Silicon Power Blaze B20 flash drive, which is not recognized by my desktop PC's both USB 3.0 ports. The flash drive's light blinks when pugged in, but no reaction from PC's side. I have tried to plug cord between flash drive and PC, but no change. It does recognize the device when plugged in any other USB 2.0 port. And the device is being recognized by other computer's both USB 2.0 and USB 3.0 ports, so I assume it is PC's fault, but I have no idea what it is. My PC's USB 3.0 ports do recognize any other USB 3.0 devices - my external HDD, other USB 3.0 devices but this drive.

    Thank you!

      My System SpecsSystem Spec

  2. #2

    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit

    I had a Lexar USB 3.0 thumb drive do something similar to that. It worked fine in my laptops USB 3 and USB 2 ports but wouldn't work in my desktops USB 2 ports. It didn't have any USB 3 ports. I ended up returning it.
      My System SpecsSystem Spec

USB 3.0 flash drive not recognized in one PCs USB3.0 ports
Related Threads
Hi there It's good to see Laptops now being fitted with at least one Native USB3 port (usually coloured BLUE). Unfortunately the only way I can try these is to use the self powered USB3 passport type devices and while my laptop has a decent Samsung 840 256GB SSD data transfer to / from the...
Hi there, After upgrading to Windows 8.1, (also happened in 8) I'm having a problem with my USB3 Seagate External HDD. For some reason my computer is not finding the drive after it's been switched off. I have to unplug-and re-plug in the USB lead for computer to recognise it. It's fine after...
Hi, I have 3 disks in my computer, of which 2 are SSDs. I swapped the SATA ports between one SSD and the HDD so as to give the SSD a SATA port with maximum 6gb/s transfer speed, and now the access to the HDD is denied. The drive letters are correct, as they should be. The user (myself,...
USB3 External Hard Drive Issue in General Support
Hi Guys, I have bought a 2TB western Digital external USB3 hard drive and installed the Asmedia drivers but windows never picks it up. See the screen capture. The drivers are the ASMedia USB 3 host controller but it seems to show up after a few seconds as USB Root Hub (xHCI) with a triangle. I...
have an Acer laptop with W8 pre-installed. It has an USB3 socket. When I plug an external drive into it the drive appears in the device manager but not in "my computer" Any help would be great. cslogg
Solved USB3 ext drive -- Weird error in Drivers & Hardware
Hi there Anybody else had this error. USB3 external drive (Samsung 1 TB self powered) connected to a USB3 Hub connected to a USB3 card on a desktop computer now no longer recognised -- not even visible and the led on the USB3 Hub fails to light up. Connect to standard USB2 slot (note USB2)...
1TB USB3 thumb drive by Kingston in Drivers & Hardware
This is what I want next Christmas. I wonder what it will cost? I'm thinking $999. CES 2013: Kingston Wields a 1TB USB Flash Drive | Maximum PC
Eight Forums Android App Eight Forums IOS App Follow us on Facebook