Windows 8 and 8.1 Forums


windows 7 is showing my usb 2.0 port as 1.0

  1. #1


    Posts : 19
    Windows 8.1 Pro X64

    windows 7 is showing my usb 2.0 port as 1.0


    I upgraded my vista computer to 7 (hp presario c751nr) and it says in device manager as having 1.0 ports... according to the specs the laptop has 3 2.0 ports. I used drivers that windows update gave me and driver pack solution software. And nothing is wrong in device manager (no missing or unworking drivers). I normally wouldnt mind but I want to put a bluetooth dongle on this laptop and it says its usb 2.0. Will it work?... sorry I know this is not on windows 7 forum but I can't get to it right now (on phone browser)
    Last edited by retrogamers17; 08 Sep 2014 at 16:03. Reason: mistake

      My System SpecsSystem Spec

  2. #2


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    So what in Device Manager makes you think its only showing USB 1.0 Ports? Normally you'll get a "This device can preform faster" when you plug a USB 2 device into a USB 1 port. USB 2 devices should work in a USB 1 port just fine. It its a WIFI dongle or something similar it may run at a reduced throughput/speed. USB drivers are backed into the Windows Install, you shouldn't need any driver update utility to get them. It wouldn't surprise me if the Driver Update utility actually caused your issue in the first place.
      My System SpecsSystem Spec

  3. #3


    Posts : 19
    Windows 8.1 Pro X64


    When I plug something in I don't get the performance popup... but I don't think it said anything about enhanced or high-speed usb. Is this just my ocd? Like I don't want to buy the bluetooth if I know it won't work
      My System SpecsSystem Spec

  4. #4


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    I would think there should be at least one "Standard Enhanced PCI to USB Host Controller" entry under Universal Serial Bus controllers in Device Manager. I have USB 2.0 and that entry in Device Manager. I think it depends on what you plug in as to whether you get that message or not. A mouse of keyboard may not do it. It may have to be an external drive that actually uses USB 2.0 speeds. It's been a long, long time since I've seen that popup.
      My System SpecsSystem Spec

  5. #5


    Posts : 19
    Windows 8.1 Pro X64


    I haven't really been trying, I've used a SanDisk usb on it and it worked great. It used to be my laptop but I recently gave it to my dad. Am I just overworrying. I'm thinking about buying him a asus bt400 bluetooth dongle
      My System SpecsSystem Spec

  6. #6


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    If your not getting the "this device can preform faster" message I wouldn't worry about it. What do you need Bluetooth for? If the bt400 Bluetooth dongle is listed as Windows 7 compatible it should be fine.
      My System SpecsSystem Spec

  7. #7


    Posts : 19
    Windows 8.1 Pro X64


    Its for my dad when he travels. He wants to catch up tv shows that he never got the chance to watch. So I should buy it?
      My System SpecsSystem Spec

  8. #8


    Posts : 19
    Windows 8.1 Pro X64


    Its for my dad when he travels. He wants to catch up tv shows that he never got the chance to watch. So I should buy it?
      My System SpecsSystem Spec

  9. #9


    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit


    I guess what is it connecting to?
      My System SpecsSystem Spec

  10. #10


    Posts : 19
    Windows 8.1 Pro X64


    Quote Originally Posted by alphanumeric View Post
    I guess what is it connecting to?
    hes using a headset... have no clue what he uses but i do know its a headset thats not a major brand.
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
windows 7 is showing my usb 2.0 port as 1.0
Related Threads
I have 3 monitors connected to an AMD HD5770 graphics card. Two monitors connect via HDMI, and the third through a Sapphire Active DisplayPort->DVI adaptor. Things have been working fine for years, but recently I started sleeping my computer when I am not using it during the day, as opposed to my...
47143 47144 47145 so i opened my port 25565 (or so i thought) went to test to see if its open on multiple sites and....all of them say its closed. :confused:
CDMA software requires a COM port to communicate with a cell phone. I'm using HW Virtual Serial Port v3.1.2 (single port, standalone install). I have a separate modem and router. My Win8.1 PC is hardwired to the modem. Windows firewall is off. Windows Defender is off. Motorola Mobile Drivers...
Howdy, I've been having an issue with my Acer S7-391. I bought the Windows 8 machine in December, and the majority of the time when I start it up in the morning, it doesn't boot properly - it hangs on a black screen for ages. I then have to hit the off button and boot it back up again...
Before anything, I don't know where to post this. Is it a hardware, installation or setup question? Anyway, here it goes, brought exactly from Technet, where I didn't get any answers so far: Mods, if I've posted it on the wrong subforum, don't feel shy to move it to the right place (if it...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook