Windows 8 and 8.1 Forums


External HDD disconnects then reconnects during file trans

  1. #1


    Posts : 13
    Windows 8.1

    External HDD disconnects then reconnects during file trans


    About a few days ago I tried copying some stuff from my old laptop to my new one with my Toshiba HDD (750GB). Some are large sizes.

    At least 2 files were corrupted and from then on out, I've been having issues with the external. The folder it was in could not be deleted. I tried EVERY possible way to delete it (it SEEMED to delete all the files when i did but it says there are still files in it). I ran all kinds of checks and defrag fixes and I assumed everything was fine (files showed up...) But now I can transfer files FROM it but not TO it. Once in a while I'd be able to get some stuff onto it but then it disconnects and says that the file I'm trying to copy from my laptop (both laptops now) is not in its location. Then the external HDD disconnects then reconnects. And I am having that folder deletion problem again.


    I have gotten some prompts that I need to reformat my external. I'm not sure if I have to do that. I have never had this issue before.

    EDIT: now I'm having issues transferring FROM the external.

      My System SpecsSystem Spec

  2. #2


    1. Well first off try some diagnostic on it. Each manufacture has a tool on there web site that you can use to check out the hard drive itself! I personally use HD Tune Pro but that's not free.

    Support :: Toshiba :: Computers, Laptops/Notebooks, Tablets, Televisions, DVD and Blu-Ray Players, Camcorders, Storage, Accessories, and more

    2. If your using USB 3.0 I would suggest you delete the USB drivers from Device Manager. reboot and they will reinstall that might help.

    3. If your hard drive checks out good, you might try a different external case. thinking maybe the chipset in the case could be failing.

    4. Use Diskpart to Clean and create a logical partition and format it NTFS

    As for losing files? you should be copying that way if something happens you still have the originals. Takes a little bit longer as you have to delete the originals once you have successfully copied them to the new location!
      My System SpecsSystem Spec

  3. #3


    Posts : 13
    Windows 8.1


    Going to give those a try.

    It's been happening on both laptops (one is windows 7, 2010). As far as accessing files, I can seem to access ones prior to last week just fine.

    Currently transfering 100GB of data from the external. So far it's going ok.....
      My System SpecsSystem Spec

  4. #4


    Posts : 13
    Windows 8.1


    While I'm transferring now, for some files t says it's not on the external/laptop when I transfer (when it is). It seems to be recently downloaded files though I had some music files where parts of the album wouldn't transfer.
      My System SpecsSystem Spec

  5. #5


    Posts : 13
    Windows 8.1


    Alright. I ran HD Tune, and attached are the results

    I did run a disk check on it last night with my friend and defragged but it seems that didn't do anything.
    Attached Thumbnails Attached Thumbnails 23-August-2014_19-29.png   23-August-2014_19-31.png  
      My System SpecsSystem Spec

  6. #6


    You have some bad sectors there.
      My System SpecsSystem Spec

  7. #7


    Posts : 13
    Windows 8.1


    Quote Originally Posted by CountMike View Post
    You have some bad sectors there.
    Figured as such. Two more were picked up when I ran HD Tune again.

    I just tried reformatting the external and midway through, it stopped. I got a prompt saying it could not format the drive.

    I think this thing may be dying.
      My System SpecsSystem Spec

  8. #8


    If you start getting more bad sectors, it likely its on it's way out. You could check connections and power again, use EaseUS Partition Master - Free Partition Magic alternative, Partition Manager Software for Windows PC and Server to repartition and zero the drive and/ or take it out from enclosure and connect it directly in case there's a fault with USB interface.
      My System SpecsSystem Spec

External HDD disconnects then reconnects during file trans
Related Threads
File history cannot recognize my external HD in Performance & Maintenance
it says File history cannot recognize my external HD. Under the icon of my external HD it says "Unknown error". Its HP SimpleSave 1TB external hard drive. Please Help. Thanks. Sent from my Windows 8 device using Board Express
Hello! I am new to this forum but I always come here searching for answers and I usually receive them. Please forgive me if I do not provide all of the necessary information. Whatever, you request I will attempt to retrieve it. Please keep in mind that I am not networking guru so I will need...
So I recently bought a Vantec SATA/IDE to USB 2.0 Adapter. Once I got it I hooked it up to my 750gb Seagate Barracuda hard drive; it let me view the files, but after I wanted to access my user folder, it said something about not having permission and closed unexpectedly. After that happened, I shut...
Running Windows 8.1 and File History was working OK for my computer, actually on two different computers worked just fine. (I never could get File History to work with Windows 8). Then suddenly this feature just up an quit. Got a little "red" flag in the Action Center. Using the control panel an...
Hello people! I have a problem like the topic might have suggested. I've tried three mice, Logitech G400, Razer Deathadder 3.5 and a random Logitech wireless but the problem remains. I haven't found any coincidents when i run a specific program or game. Sometimes it goes a day or two without...
Help. This is driving me nuts. Not sure what's happened and pretty sure I have not done anything to silly. Background : New Windows8 install all update and drivers : system running absolutely fine. Issue :Copying data from one drive to another via any hub on system...
Hi guys, My external WD passport started showing up as empty and I can't access it directly in explorer. I ran a few chkdsk commands and it came back clean. When I attached it to another USB slot, it came up as being RAW instead of the default NTFS. Everything shows up fine in Stellar Phoenix...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook