Windows 8 and 8.1 Forums


USB 3.0 Pendrive not working in front usb 2.0 port

  1. #1


    Posts : 22
    Windows 8.1 Pro

    USB 3.0 Pendrive not working in front usb 2.0 port


    Hey guys i bought hpx705w usb 3.0 drive.Its not working in front usb ports of my desktop but works fine when plugged in back usb ports.And also works fine on my laptop usb ports. What should i do ?
    Running windows 8

      My System SpecsSystem Spec

  2. #2


    Forever West
    Posts : 591
    WinVista, Win7, Win8.1, Win10, Mac OS X 10.10, Linux Mint 17.1


    Do any other USB devices work when plugged into the front ports?
      My System SpecsSystem Spec

  3. #3


    Posts : 22
    Windows 8.1 Pro


    Quote Originally Posted by Berton View Post
    Do any other USB devices work when plugged into the front ports?
    Yes, other devices are working when plugged in front ports . That means there isn't anything wrong with ports
      My System SpecsSystem Spec

  4. #4


    Forever West
    Posts : 591
    WinVista, Win7, Win8.1, Win10, Mac OS X 10.10, Linux Mint 17.1


    I've seen speculation that some front ports simply don't get the same amount of power from the motherboard as the rear ports do, seems to be valid. I have a couple of computers that don't have front ports so I use USB Hubs that fit in place of a floppy drive and take their power from the power supply, similar to the External USB Self-Powered Hubs.
      My System SpecsSystem Spec

  5. #5


    Posts : 22
    Windows 8.1 Pro


    Quote Originally Posted by Berton View Post
    I've seen speculation that some front ports simply don't get the same amount of power from the motherboard as the rear ports do, seems to be valid. I have a couple of computers that don't have front ports so I use USB Hubs that fit in place of a floppy drive and take their power from the power supply, similar to the External USB Self-Powered Hubs.
    I dont think its a power issue as other devices seems to be working fine on same ports but its just this usb 3.0 pendrive that dont work.
    Do u think it might be a driver issue ?
      My System SpecsSystem Spec

  6. #6


    It's strange. In my case The problem is when I connect older USB 2.0 Phones/Devices to my USB 3.0 ports. It recognizes the mobiles but I cant see storage space (cards).

    Have you tried to assign a drive letter to the device using Disk Management?

      My System SpecsSystem Spec

  7. #7


    Sunnyvale, CA USA
    Posts : 283
    Windows 8.1 Pro with Media Center (64-bit)


    I have had some difficulty with certain types of USB 3 drives. For example, I have 2 Patriot TAB USB 3 drives that I keep connected to the front panel USB3 ports. Just recently I upgraded them to the same type, but larger size. One works fine, but the other only works at USB 2 speeds in the front. On the back panel it will run at USB3 speeds. Since one works fine and the other doesn't, I suspect the physical construction of the USB 3 pins on the drive that are recessed is somehow involved.
      My System SpecsSystem Spec

  8. #8


    Posts : 22
    Windows 8.1 Pro


    Quote Originally Posted by arachnaut View Post
    I have had some difficulty with certain types of USB 3 drives. For example, I have 2 Patriot TAB USB 3 drives that I keep connected to the front panel USB3 ports. Just recently I upgraded them to the same type, but larger size. One works fine, but the other only works at USB 2 speeds in the front. On the back panel it will run at USB3 speeds. Since one works fine and the other doesn't, I suspect the physical construction of the USB 3 pins on the drive that are recessed is somehow involved.
    So what should i do now ?
      My System SpecsSystem Spec

  9. #9


    Posts : 22
    Windows 8.1 Pro


    Quote Originally Posted by vrosa View Post
    It's strange. In my case The problem is when I connect older USB 2.0 Phones/Devices to my USB 3.0 ports. It recognizes the mobiles but I cant see storage space (cards).

    Have you tried to assign a drive letter to the device using Disk Management?

    Its not listed in disk management.
      My System SpecsSystem Spec

  10. #10


    Sunnyvale, CA USA
    Posts : 283
    Windows 8.1 Pro with Media Center (64-bit)


    Quote Originally Posted by zafar khan View Post

    So what should i do now ?
    I can only suggest you get a USB extension cable and run it from the back, use that in the front.

    Or perhaps you can exchange it for another and see if the problem goes away.
      My System SpecsSystem Spec

USB 3.0 Pendrive not working in front usb 2.0 port
Related Threads
Right, i've been having this problem since I THINK starting to use a HDMI wire. But now, i cannot get any audio from the audio jacks, they are detected, but no sound is produced and I just cannot figure it out. I've disabled the HDMI, installed, un-installed, re-installed audio drivers and pretty...
Ethernet port not working in Network & Sharing
just noticed my Vaio ethernet port isn't working. it says the adaptor is working normally, but when I plug in an ethernet cable is says the cable is not plugged in. I tried it with two different cables that work elsewhere. I wonder if the laptop ethernet card is faulty? Wireless is working...
I have a Gigabyte GA-F2A75m-HD2 (Rev 1.0) board and this is quite an odd one. The front port worked with Ubuntu and other Linux distros but it seems to be the opposite case with Windows 8.1. I installed the latest Gigabyte version of the Realtek HD Audio Manager but it still doesn't work. What...
I've installed windows 8 yesterday and noted that front panel audio doesn't work (I use a headphone) connecting the headphone to back jack it's work but front not. It's a Intel HDA, and using windows's default driver. any needed information tell me, and sorry my bad english.
USB 3.0 port not working in Drivers & Hardware
Hi guys, I'm new to this forum, and I am having trouble with my USB 3.0 port. Whenever I plug anything (usb, mouse, portable hard drive etc) into that particular port, "Client Server Runtime Process" would use 100% of the CPU. However, when plugged into the USB 2.0, all seems to be fine. Would...
Hello everyone, I am using Windows 8 64 bit Pro. After my ps/2 mouse was giving problems I recently switched to using a wireless usb mouse. Now when that didn't suit me I wanted switch back to a ps/2 mouse. But the problem is that now when I attach the mouse to the ps/2 port,...
USB Port not working after upgrade in Drivers & Hardware
Got as far as the initial Personalisation screen (background colour) following an upgrade from 7 to 8 Pro and no keyboard or mouse working (wireless). Tried a hardwired keyboard/mouse and even dug out an old keyboard with a PS2 connector, none worked. Looked at the xbox receiver I have plugged in...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook