Windows 8 and 8.1 Forums

USB Drive Write Protected itself, unable to remove

  1. #1

    Posts : 2

    USB Drive Write Protected itself, unable to remove

    Hi all,

    Please can somebody help me, I've a relatively new SanDisk Cruzer Slice 64GB USB pen drive, which I use for work mainly. It has somehow managed to write protect itself and no matter what I do I simply cannot remove it!

    I've scanned with Antivirus, nothing found

    I've tried regedit - Computer\HKEY_LOCAL_MACHINE\SYSTEM\

    StorageDevicePolices didn't exist so I created a 32 bit Dword string, set to 0 this hasn't done anything

    I've tried Diskpart as administrator -
    DISKPART> list disk
    Disk ### Status Size Free Dyn Gpt
    -------- ------------- ------- ------- --- ---
    Disk 0 Online 298 GB 1024 KB
    Disk 1 Online 59 GB 0 B
    DISKPART> select disk 1
    Disk 1 is now the selected disk.
    DISKPART> attributes disk clear readonly
    Disk attributes cleared successfully.
    DISKPART> clean
    DiskPart has encountered an error: The request could not be performed because of
    an I/O device error.
    See the System Event Log for more information.

    I've checked the logs and it doesn't seem to list anything for the drive

      My System SpecsSystem Spec

  2. #2

    Posts : 151
    Win8 Pro

    How is the disk formatted? FAT32 (I believe the default, could be wrong) or NTFS?

    If it's FAT32, and you are trying to copy a file larger than 4GB, then it's not going to let you write to it due to the limitations of FAT32. You would have to re-format the disk to NTFS.

    It also could be possible that the disk became corrupted during a write operation (ie., not using "remove") in the system tray when unplugging the drive from the computer...

    Copy whatever files you currently have on the disk to your HD for temporary safekeeping and format the disk again.

    Also, what version of Windows are you using? Is it the Professional version or Home version? Are you using, or did use, bitlocker on this machine? Or a TPM? If you did, bitlocker automatically changes some policies to read only for removeable drives, and if you have Windows 8 Pro, we can go in a fix that throught the group policy editor.
    Last edited by lastof; 14 Aug 2014 at 20:21.
      My System SpecsSystem Spec

  3. #3

    Posts : 2

    Its NTFS, it also only actually has just under 5GB of space used on it.

    I can't actually format the drive each time I try I get an error message about the drive being write protected
      My System SpecsSystem Spec

  4. #4

    Posts : 151
    Win8 Pro

    If you tried everything and are still failing to be able to remove the write protection, follow the link below and go to "Samy Youssef's" post near the bottom of the page, many of the people who were experiencing the same problems as you were able to get the drive restored to default functionality by following his directions:

    Usb flash drive write protected cannot format - Flash Media - Storage
    Last edited by lastof; 14 Aug 2014 at 20:36.
      My System SpecsSystem Spec

USB Drive Write Protected itself, unable to remove
Related Threads
i created usb bootable disk using rufus it made usb drive write protected now i cant formated i tried almost all possible ways available in net 1. i used disk part method and changed attributes still same 2. i used reg edit method and change device storage properties result same
Hi! I have to format my SSD in cmd, and have tried this command: "Attributes Disk Clear Readonly" This should usually work fine in most cases, but the message I get says it's not allowed. The SSD is my former boot-disk with Win 8 installed on it. Does anyone know a command or e...
Should I create my own Wallpaper directory or somehow (not sure how) make this directory writeable since it is set up as read only and cannot be changed easily. Thanks Peter
When I try to format my flash drive it shows that the drive is Write-Protected. When I tried to remove it through diskpart it said it completed successfully, but when I try to format it again it still didn't work. I also tried removing it using REGEDIT with storagedevicepolicies, but that STILL...
remove disk write protected in Drivers & Hardware
my 8gb tdk usb flash drive has suddenly come up with the error 'disk write protected'. there is no external switch to toogle the disk write protection. i have tried 1 method that was said to work but hasn't for me... create a key called 'SystemDevicePolices' under HKEY LOCAL...
I have an 8GB flash drive that's write protected. There is no lock/unlock on the flash drive. How can I reformat/erase the contents so I can use the flash drive for other things? I've tried low level and that didn't work. Thank you.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook