Windows 8 and 8.1 Forums


USB Device does not autoplay

  1. #1


    Posts : 40
    Windows 8.1

    USB Device does not autoplay


    Hey.

    I've just come across an error which is quite frustrating. I use a Sandisk Cruzer Extreme USB 3.0 32gb flash drive. When I plug the flash drive in, autoplay does not come up however the flash drive shows up on My Computer, but not Device Manager. It does not show up on the tray (the "Safely Remove Hardware" icon), but other USB flash drives do. The drive is fully working and I can transfer files to and from the drive, I just cannot autoplay nor eject the drive safely.

    I've done the obvious such as ensuring autoplay is enabled, formatting the drive, trying different ports, and now I'm not sure what the problem can be.

    I've observed that it's only the first USB port on the front panel that has this problem, but all other USB drives autoplay fine on this port. (I think only usb 2.0 - 3.0 devices do not autplay)



    Any help would be good, cheers.

      My System SpecsSystem Spec

  2. #2


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Newer Sandisk flash drives, to be compatible with Microsoft's Windows to Go feature of Windows 8, have to be set as Fixed drives rather than Removable.
    Here's a screen shot, I have 2 sandisks 16GB each and disk management show 1 to be removable and the other is a Basic Disk.
    Click image for larger version
    As for showing in system tray. Perhaps you might want to set your BIOS to enable hot swap for Basic Disk.
    Autoplay is a nice & convenient feature. However, it is a way for Malwares and Virus to sneak in your PC. I always disable this feature.
      My System SpecsSystem Spec

  3. #3


    Posts : 40
    Windows 8.1


    Quote Originally Posted by topgundcp View Post
    Newer Sandisk flash drives, to be compatible with Microsoft's Windows to Go feature of Windows 8, have to be set as Fixed drives rather than Removable.
    Here's a screen shot, I have 2 sandisks 16GB each and disk management show 1 to be removable and the other is a Basic Disk.
    Click image for larger version
    As for showing in system tray. Perhaps you might want to set your BIOS to enable hot swap for Basic Disk.
    Autoplay is a nice & convenient feature. However, it is a way for Malwares and Virus to sneak in your PC. I always disable this feature.
    It doesn't even make the sound when being plugged in or out but it does for other usb 3.0 ports, even though they're set to removable with the same usb drive. It's something wrong with the port configuration or something along those lines.
      My System SpecsSystem Spec

USB Device does not autoplay
Related Threads
Autoplay Not Working with 8.1 in General Support
For the past few months I've noticed that Autoplay does not come up, on my PC anymore, when I insert a CD or any flash drive. I have had Windows 8 since April 2013 and I upgraded to 8.1 a few months ago. I have looked all over Google for help and answers but nothing seems to be working. I...
Solved AutoRun/AutoPlay tile in Drivers & Hardware
I have a thumb drive that I regularly plug in and out of the front of my tower using the same USB port. The drive has an assigned letter. Plugging it in is no problem. It is detected fine and I have AutoPlay set to do nothing. I do not desire to use the AutoRun/AutoPlay on the desktop taskbar to...
AutoPlay Importing Pictures in Software and Apps
So I've got a little issue here with auto play and importing pictures. The import pictures feature from windows 7 is in windows 8, but it's a bit harder to find. I can import pictures with the pictures app, but it doesn't import pictures the way I like, nor does it let me change settings (if...
AutoPlay Ask Me Window in General Support
I've set the AutoPlay option for some devices to "Ask me every time". When AutoPlay is activated on those devices, I get kind of a notification box at the upper right of the screen (that fades away) that I have to click on to get my choices of what to do. Is there a way to have it just open the...
AutoPlay in Installation & Setup
There is an app here that, when opened, causes all AutoPlay optical media settings to revert to "Take No Action." Is there an AutoPlay setting that can thwart this, in the same manner that a file can be set to READ ONLY?
Solved AutoPlay does not launch in General Support
When I insert a memory card or thumb drive I expect autoplay to launch, but it doesn't. Working on desktop, when I right click the drive in File Explorer, I can open AutoPlay and select an action. But after doing so, then removing and reinserting the card or drive, nothing happens. Any...
Solved Autoplay in Installation & Setup
Hi all, below are snips of autoplay in 7 and 8. At the top of the one from 8 it shows "Storage devices", not so in the one from 7. Is this new in 8 or is my 7 corrupted? I had the same flash drive connected for both shots. 1277 1278
Eight Forums Android App Eight Forums IOS App Follow us on Facebook