Windows 8 and 8.1 Forums


Problem with antec khuler 920, possibly related to motherboard drivers

  1. #1


    Posts : 7
    Windows 8 Consumer Preview 64-bit

    Problem with antec khuler 920, possibly related to motherboard drivers


    My CPU cooler, an Antec Khuler H2O 920, is powered by internal USB 2.0. This allows the radiator and fans to be controlled from a program inside Windows (ChillControl). The fans and radiator pump work, but I am unable to get the fans to run any faster than idle (this is important for doing anything that significantly uses the cpu). Normally controlled by the ChillControl utility, I get this error when the utility starts:
    Cannot connect to Chill Control device. Check USB connection on device and restart the Chill Control Application
    The cooler is certainly connected because the hardware still works and was not changed at all when upgrading to Windows 8. I contacted Antec customer support about it, and they had no idea.

    Here is my speculation: I have an Asus P6-X58E-Pro motherboard, and Asus does not seem to have drivers for Windows 8 available. Because the cooler is powered and controlled by internal USB, and the error I get seems to be related, this may be a motherboard driver issue.
    Based on that, I'm not really sure what to do. Thank you in advance for the help

      My System SpecsSystem Spec

  2. #2


    Covington, La
    Posts : 1,184
    Windows 7 HP 64bit, Windows 8.1 Pro w/Media Center 64BIT


    Can you look at each USB hub in Device Manager and see if it shows up?

    Jim
      My System SpecsSystem Spec

  3. #3



    The Contemplator
    (1963-2013)
    Doncaster, UK
    Posts : 638
    Windows 8.1 Pro RTM x64


    I don't think that it is a motherboard driver issue, more an Antec one (specifically ChillControl compatibility). If CC worked on previous versions of Windows, such as XP, Vista, or Windows 7, have you tried running it in compatibility mode?
      My System SpecsSystem Spec

  4. #4


    Posts : 7
    Windows 8 Consumer Preview 64-bit


    Quote Originally Posted by Phone Man View Post
    Can you look at each USB hub in Device Manager and see if it shows up?

    Jim
    Here is what I am seeing - not exactly sure what to look for, but here is a screen shot:



    err.. probably can't see that. http://i228.photobucket.com/albums/e...icemanager.png
      My System SpecsSystem Spec

  5. #5


    Posts : 7
    Windows 8 Consumer Preview 64-bit


    Quote Originally Posted by Dwarf View Post
    I don't think that it is a motherboard driver issue, more an Antec one (specifically ChillControl compatibility). If CC worked on previous versions of Windows, such as XP, Vista, or Windows 7, have you tried running it in compatibility mode?
    I have not tried compatibility mode yet, but let me see if that makes a difference, be right back.
      My System SpecsSystem Spec

  6. #6


    Posts : 7
    Windows 8 Consumer Preview 64-bit


    Quote Originally Posted by Dwarf View Post
    I don't think that it is a motherboard driver issue, more an Antec one (specifically ChillControl compatibility). If CC worked on previous versions of Windows, such as XP, Vista, or Windows 7, have you tried running it in compatibility mode?
    I get the same error as before when I try to start it, after setting compatibility mode for the applications

      My System SpecsSystem Spec

  7. #7



    The Contemplator
    (1963-2013)
    Doncaster, UK
    Posts : 638
    Windows 8.1 Pro RTM x64


    I would say that this confirms my earlier theory of it being a compatibility problem with the CC driver. The system has recognised that there is a device connected to the port, hence the Unknown USB Device message, but it doesn't know what it is or what to do with it (which is where the driver comes in).

    What OS were you running before? Have you tried installing the driver in compatibility mode as though you were installing it in that OS?
      My System SpecsSystem Spec

  8. #8


    Posts : 7
    Windows 8 Consumer Preview 64-bit


    Quote Originally Posted by Dwarf View Post
    I would say that this confirms my earlier theory of it being a compatibility problem with the CC driver. The system has recognised that there is a device connected to the port, hence the Unknown USB Device message, but it doesn't know what it is or what to do with it (which is where the driver comes in).

    What OS were you running before? Have you tried installing the driver in compatibility mode as though you were installing it in that OS?
    Hmm, that makes sense. I was using Win 7 Home Premium x64 before and just did an upgrade install for Win 8. How do you install something specifically in compatibility mode?
      My System SpecsSystem Spec

  9. #9


    Covington, La
    Posts : 1,184
    Windows 7 HP 64bit, Windows 8.1 Pro w/Media Center 64BIT


    Run the Compatibility Troubleshooter and see what it recommends. I had one driver that was for Win 7 and it recommended I use XP SP3 and it worked.

    Jim
      My System SpecsSystem Spec

  10. #10


    Posts : 7
    Windows 8 Consumer Preview 64-bit


    Quote Originally Posted by Phone Man View Post
    Run the Compatibility Troubleshooter and see what it recommends. I had one driver that was for Win 7 and it recommended I use XP SP3 and it worked.

    Jim
    Good thought, I tried each of the different options and had the same result regardless (which is why I am concerned it may not be an issue with this application, but something else).
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Problem with antec khuler 920, possibly related to motherboard drivers
Related Threads
Hello all, for a'while I had been wondering why there were so many grayed out and seemingly out of place drivers on my laptop. For them to be grey, I assume they simply are not being used at the moment. I believe they may have been the leftovers from the stress testers and the tech team that worked...
Solved BSOD possibly due to corrupted memory drivers in BSOD Crashes and Debugging
I asked my question on micorsoft community but they answered a few times then simply stopped answering, all I was told is that it maybe possibly due to corrupted memory drivers. I either get the BSOD with the DPC_Watchdog_Violation error or my laptop just freezes and a constant buzzing sound...
Hello All, I have a desktop PC with an MSI A78M-E45 motherboard. I just did a fresh install of Windows 8.1 Pro and everything is working perfectly (display, hard drives, USB, etc.). I was wondering, since everything is working fine should I even bother to install the drivers that came with my...
Hi all, My laptop is running ok but I have noticed that certain programs have been taking a lot longer than usual to install/update (e.g. iTunes) but they always do. Then the last few days AVG Antivirus has been wanting to auto-update the software (not just the virus definitions) but each time...
I believe i have royally screwed myself over. I recently bought a windows 8 gateway desktop computer, with an AMD processor and integrated video. I installed an external video card to compare the baseline and performance to the integrated one. After realizing it wasn't as good. I removed it and got...
Solved Asus Motherboard Drivers CD won't run in Installation & Setup
I have an Asus P5QL VM DO montherboard in my homemade PC. This is an older system that I use for testing, so I put my Windows 8 install on it. Unfortunately, the Asus driver installation CD will not run in Win 8, and I am missing one driver which I am unable to locate anywhere. It is for the PCI...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook