Windows 8 and 8.1 Forums


1 of 3 USB Ports Stopped Working Post Windows 8.1 Upgrade

  1. #1

    1 of 3 USB Ports Stopped Working Post Windows 8.1 Upgrade


    Post upgrading to Windows 8.1 Pro on a Dell XPS15, 'only' 1 of the 3 USB ports has stopped working. The other 2 are working fine. I have the latest BIOS A16.

    I've uninstalled all USB drivers and had them auto-resintall on boot. No change, 1 USB port (the one with powershare) is still not working.

    I'm not getting much on the Dell forums for this. Any ideas how to fix.

      My System SpecsSystem Spec

  2. #2


    Posts : 151
    Win8 Pro


    Did you check the power options? USB Selective suspend could be the problem

    Windows Key + X > Control Panel > Power Options > Change Plan Settings > Change Advanced Settings > USB settings > toggle the 'USB Selective suspend' setting to enabled if it is disabled, or disabled if it is enabled. Apply and reboot. If it doesn't work upon reboot, toggle it one more time and reboot again.
      My System SpecsSystem Spec

  3. #3


    Thanks a lot for the suggestions, but no luck. Tried a few toggles and reboots. No change.
      My System SpecsSystem Spec

  4. #4


    Posts : 151
    Win8 Pro


    Does the port show up in Device manager? If so, is it showing an error? What driver is it using? If powershare is a proprietary feature from Dell, I don't think the Microsoft system drivers will support its functionality.

    Did you install the chipset and/or USB drivers from Dell?
      My System SpecsSystem Spec

  5. #5


    Yeah I've installed every available driver. There is one device under "other devices" which does not have a driver, not available from MS. Maybe this is it. No errors, not sure which driver it is, as there are 3 USB ports and 7 drivers installed, plus the one under other devices which may be it. I've tried a resintall of W8.1 today and still not working. I'd say it's either a faulty motherboard or this missing device driver.

    Thanks for the help
      My System SpecsSystem Spec

  6. #6


    It's fixed itself. Just by chance I've been having a few issues trying to setup UEFI with Windows, so after about 3 installs, trying different and unrelated things, the USB port is working again. Amazing!
      My System SpecsSystem Spec

1 of 3 USB Ports Stopped Working Post Windows 8.1 Upgrade
Related Threads
Hello everyone, My pc specs are as follows: 1)Intel 4670 K 2)Asus Sabertooth Z87 3)12 GB DDR3 ram 4)Windows 8.1 Pro x64 5)Razer DeathAdder 2013 mouse 6)Logitech Usb keyboard
USB 3.0 ports not working in Drivers & Hardware
Hi there... So, my USB 3.0 ports are not working with my USB 3.0 ext-HDD. It's an ADATA Nobility NH13 I don't have any other USB 3.0 equipment to test, but the ext-HDD works perfectly on my laptop and on my TV as well, so it's definitely not the HDDs fault. When I plug in USB 2 devices, they...
And it happens only when I boot the computer up and find that neither my keyboard or mouse are working then I plug them into front (2) avaialable usb ports and they work fine.... And then If I try to uninstall universal bus controllers by device manager then my keyboard + mouse stops working...
usb 3.o ports suddenly not working in Drivers & Hardware
I dont know why but my external hard drive isnt showing up when connected.. Windows makes the connection noise when I plug it in but it dont show up in disk management, device manager or anywhere else... If I plug it into a regular usb port it works fine... And its a usb 3.0 capable drive it worked...
USB Ports not working in Drivers & Hardware
Ok so I have a windows 8 64 bit machine. I have a xerox personal scanner as well as a dell 2330d printer. My issue is that the scanner only works if i have it plugged into one of my usb ports on the front of my machine and will not work on any that are on the back of the machine. As for my...
Recently I installed a fresh, clean install of Windows 8 pro 64 bit on a sony vaio laptop vgn-z540n model, and then did a restoration of Windows settings and files from windows easy transfer (wasn't able to transfer everything though). After that, installed most of the drivers that to make the...
Solved None of my USB ports are working. in Drivers & Hardware
I hope this is the right place to post. So I upgraded this morning from windows 7 to 8 and it all seemed to be working alright. Then my usb ports stopped working. Can't use mouse, doesn't recognize external hard drive or anything else. For the first few minutes it was all working ok and I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook