Windows 8 and 8.1 Forums

RAIDR Express PCIE SSD doesn't work on Sabertooth Z97 Mk1

  1. #1

    RAIDR Express PCIE SSD doesn't work on Sabertooth Z97 Mk1

    I am trying to install Windows 8.1 on my Asus RAIDR Express PCIe SSD which is mounted on an Asus Sabertooth Z97 Mark 1 MoBo with an Asus GeForce GT630 graphics card, but Windows does not recognise the SSD.

    Both the SSD and the GPU are on the Qualified Vendors List published by Asus for this motherboard, so it should not be a problem.

    When I am trying to install Windows and get to the point where I should choose the drive on which to install Windows, the SSD is not shown.

    Has anyone successfully used this setup and can give me some pointers on what I should do?

    I have tried changing :-
    1. 'Boot from PCIe/PCI expansion devices' from [Legacy OpROM first] to [Both, UEFI first];
    2. 'Boot from storage devices' from [Legacy OpROM first] to [Both, UEFI first];
    3. 'Launch CSM' from [Enabled] to [Disabled] with 'Secure Boot' staying as [Windows UEFI Mode];
    4. 'Intel Rapid Storage Technology' from [On] to [Off], which changes SATA Mode Selection from [AHCI] to [RAID].

    None of these ideas worked. There is an updated version of the BIOS and one of the results of this update is 'Enhance compatibility with some PCIE device', but I have no idea whether this will help to solve my problem, and I am reluctant to flash the BIOS on the off chance.


      My System SpecsSystem Spec

  2. #2

    Hi Welcome to W8F,

    You might need to try updating the BIOS first and find out if it will resolve your issue. Keep us posted.
      My System SpecsSystem Spec

  3. #3


    At the moment I am waiting to see if Asus technical support can suggest anything which does not involve updating the BIOS as I destroyed a MoBo a few years ago when updating a BIOS, but I think that I will probably have to try this in a day or two.

      My System SpecsSystem Spec

  4. #4

    I am happy to report that John from Asus made a suggestion which worked.

    My setup is :-
    Asus RAIDR Express PCIe SSD;
    Asus GT630-SL-2GD3-L GPU;
    Asus SABERTOOTH Z97 MARK 1 Motherboard, BIOS version 0602.

    The trick is to remove the GPU, connect the monitor to either the HDMI or DisplayPort port, boot the computer and Windows can then be installed.

    Then re-install the GPU and connect the monitor to the GPU and reboot the computer and Windows is happy, and so was I. At least I did not need to try updating the BIOS.

      My System SpecsSystem Spec

RAIDR Express PCIE SSD doesn't work on Sabertooth Z97 Mk1
Related Threads
Pin to Taskbar doesn't work in General Support
At first it work fine but when I unpin and tried to pin to taskbar again it didn't work. The options available, I can select pin to taskbar but it didn't appear in taskbar(No.3 in the screenshot). You can see in the picture, the option in No.1 work fine, I can select to pin/unpin but not work as...
Title: My stereo mix doesn't work well My PC: SP 2000-2b49Ca, window8 Audio: Realtek driver: (installed sept 21 2013) Panel settings: External Mic: ready, level 75+20dB, 3,5mm connector Microphone: ready, level 75+20dB, ATAPI internal connector Stereo mix: default, level 75, no...
WindowBlinds doesn't work in Software and Apps
Just in case anyone is curious, WindowsBlinds, the new version 7+, does not work. Not only does it NOT change the display, more seriously, depending on the theme you select, it totally hoses up the display so that all you get is a black screen with a mouse cursor. I was trying this because my...
GPU Sometimes Doesn't Work in Graphic Cards
Hey all, Not sure where to post this so thought I would try here. Ever since I've put together my new PC I have had an issue with my wireless card. Sometimes when I start up my PC the driver doesn't load for it, I can see it in the device manager list but the driver hasn't loaded and when I...
Solved My Windows Key doesn't work in General Support
I had been using the Windows key to switch back and forth from Metro to desktop. When I am in Metro, pressing it does nothing, but it works everywhere else. I simply click on the desktop icon, so it's no big deal, but is there a solution?
WIN + Tab doesn't work but ALT + Tab does Has anyone else observed this?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook