Windows 8 and 8.1 Forums


No USB ports working after latest windows update installed

  1. #1


    Posts : 12
    Windows 8 pro x64

    No USB ports working after latest windows update installed


    Hello everyone,

    My pc specs are as follows:

    1)Intel 4670 K
    2)Asus Sabertooth Z87
    3)12 GB DDR3 ram
    4)Windows 8.1 Pro x64
    5)Razer DeathAdder 2013 mouse
    6)Logitech Usb keyboard

    My pc was working fine until yesterday night when july windows update was downloaded and installed.

    Then when today morning i booted up my pc all my usb devices stopped working, I cannot use my mouse or keyboard when my windows is booted.

    However, I am able to use my mouse and keyboard fine in UEFI bios without any issue.

    I tried clearing cmos,changing ports,enable and disable legacy usb in bios,enable and disable intel xhci still my mouse and keyboard are not working when windows boots up.

    I tried system restore using windows 8 cd but it ends up giving some error during restore and says unable to restore.

    I am able to access my system registry and explorer using the windows 8 cd.

    Is there anyway i can solve this issue without having to format my pc?.

    Thank you,I hope i provided all the info needed for the topic if I am missing anything please let me know.

      My System SpecsSystem Spec

  2. #2


    Can you boot in Safe Mode ?
      My System SpecsSystem Spec

  3. #3


    Posts : 12
    Windows 8 pro x64


    um.. no i can't boot to safe mode but even if i do boot even in safe mode mouse and keyboard doesn't work.

    I googled a lot on this problem and many said they could not type or move mouse in safe mode.

    I am thinking of reinstalling windows again as a last choice though i wish it doesn't come to that.
      My System SpecsSystem Spec

  4. #4


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    1. Please double check with ASUS if they have update for your BIOS.
    2. Connect your Keyboard/Mouse to USB2 port instead of USB3.
    3. Install the latest Intel Chipset Drivers. This will install neccessary drivers for all built in devices of the Mother Board including the USB's. https://downloadcenter.intel.com/Det...adType=Drivers
      My System SpecsSystem Spec

  5. #5


    Posts : 12
    Windows 8 pro x64


    Quote Originally Posted by topgundcp View Post
    1. Please double check with ASUS if they have update for your BIOS.
    2. Connect your Keyboard/Mouse to USB2 port instead of USB3.
    3. Install the latest Intel Chipset Drivers. This will install neccessary drivers for all built in devices of the Mother Board including the USB's. https://downloadcenter.intel.com/Det...adType=Drivers
    1.Yes i checked and i already have the latest bios for my motherboard version 2004.
    2.As i said previously i already tried all usb ports including 2.0 and 3.0 none of them work.
    3.Yes i am already using the latest intel chipset driver but now i cant reinstall it as i cannot navigate through windows.

    Thank You for your continuous help really appreciate it
      My System SpecsSystem Spec

  6. #6


    Perth, Western Australia
    Posts : 69
    7 Pro & 8.1 Pro & 8.1 Pro


    I have an Asus Deluxe/Dual motherboard. This has 6 USB3 ports in the back and 2 in the front. The two middle ones in the back and the front ones work perfectly. The other 4 in the back just don't work.... They run slow and they don't recognise any external drives plugged into them and generally only work ONCE with each NEW peripheral.

    Contacting Asus wasn't any help whatsoever. They just loaded me with silly policies and procedures but didn't come up with any helpful suggestions.

    I have virtually accepted that I have 4 out of 8 working USB3. I cracked open some external HDDs and installed them internally to avoid using the non-functioning USB3 ports. Luckily my MB has 10 internal SATA ports.

    Hope you have better luck with your problem....

    OBTW I DID update drivers etc etc
      My System SpecsSystem Spec

  7. #7


    Perth, Western Australia
    Posts : 69
    7 Pro & 8.1 Pro & 8.1 Pro


    Happily I don't have any problems with the USB2 ports my mouse and keyboard are plugged into.... I have 8 USB2 ports too.
      My System SpecsSystem Spec

  8. #8


    Posts : 12
    Windows 8 pro x64


    Well unfortunately I was unable to find solution for this.

    Hence I booted up fedora live cd and backed up all data and reinstalled windows again.

    Now its working fine.

    I would say windows update installed non compatible driver for one of my devices causing usb driver corruption.
      My System SpecsSystem Spec

  9. #9


    When I installed yesterdays updates on 8.1 pro, I completely lost the ability to scroll with the mouse wheel.
    Made an image with Drive Snapshot before installing JIC. Restored and tried again. Twice. No scrolling. I should have tried to re-install Logitech Setpoint. That may have helped. I tried changing settings in SP, didn't help.
      My System SpecsSystem Spec

  10. #10


    Perth, Western Australia
    Posts : 69
    7 Pro & 8.1 Pro & 8.1 Pro


    I tried to update the drivers but Windows confirmed that I had the "best drivers for the devices".

    I have hardware and software RAID mirrors so reloading Windows is not an option for fear of losing the mirrors.

    So I just live with it.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
No USB ports working after latest windows update installed
Related Threads
Post upgrading to Windows 8.1 Pro on a Dell XPS15, 'only' 1 of the 3 USB ports has stopped working. The other 2 are working fine. I have the latest BIOS A16. I've uninstalled all USB drivers and had them auto-resintall on boot. No change, 1 USB port (the one with powershare) is still not...
USB 3.0 ports not working in Drivers & Hardware
Hi there... So, my USB 3.0 ports are not working with my USB 3.0 ext-HDD. It's an ADATA Nobility NH13 I don't have any other USB 3.0 equipment to test, but the ext-HDD works perfectly on my laptop and on my TV as well, so it's definitely not the HDDs fault. When I plug in USB 2 devices, they...
Yesterday I installed an update for Win 8.1 (It was around 90 some mb) after I login I only get a black screen with a useless white cursor. Screensaver works fine, when I do a CNTRL/SHIFT/ESC the task manager box pops up for a few seconds and disappears. I was able to create another user account...
I just updated maybe half an hour ago and now I can't use the start as its frozen as a white window icon. IS this a known issue, and is there a fix? Doing a system restore solves it - but then I'm rolled back and continually prompted that it'll update on my next restart. Moving the menu to the...
usb 3.o ports suddenly not working in Drivers & Hardware
I dont know why but my external hard drive isnt showing up when connected.. Windows makes the connection noise when I plug it in but it dont show up in disk management, device manager or anywhere else... If I plug it into a regular usb port it works fine... And its a usb 3.0 capable drive it worked...
USB Ports not working in Drivers & Hardware
Ok so I have a windows 8 64 bit machine. I have a xerox personal scanner as well as a dell 2330d printer. My issue is that the scanner only works if i have it plugged into one of my usb ports on the front of my machine and will not work on any that are on the back of the machine. As for my...
Solved None of my USB ports are working. in Drivers & Hardware
I hope this is the right place to post. So I upgraded this morning from windows 7 to 8 and it all seemed to be working alright. Then my usb ports stopped working. Can't use mouse, doesn't recognize external hard drive or anything else. For the first few minutes it was all working ok and I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook