Windows 8 and 8.1 Forums


USB devices take time to initialize at boot. Why?

  1. #1


    Posts : 6
    Windows 8.1 Update 1

    USB devices take time to initialize at boot. Why?


    I have a weird issue in which after a boot of the machine it will take some time for USB devices to become initialized, yes... this includes my USB keyboard and mouse. So essentially even though the system may be up and running at the user logon screen, I have to wait five seconds until I can type my password in on my USB connected keyboard.

    Anyone else have this issue? Any possible fix for this?

      My System SpecsSystem Spec

  2. #2


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Ok, my standard first fix step. Uninstall USB hubs in Device Manager, reboot and let everything re-install. See if any better.

    You didn't say if it has always been this way or just started.
      My System SpecsSystem Spec

  3. #3


    Posts : 6
    Windows 8.1 Update 1


    I took a look at Device Manager and found a weird entry in the USB devices tree.
    Unknown USB Device (Device Descriptor Request Failed)

    So I went through all of my USB devices and unplugged them one by one until I found the offending USB device. Removed that device and rebooted the machine, no more pause with USB devices.

    Consider this problem fixed!
      My System SpecsSystem Spec

  4. #4


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Glad you found the problem!
      My System SpecsSystem Spec

USB devices take time to initialize at boot. Why?
Related Threads
Okay, so everytime I run Chkdsk it always finds errors on the disk. I am unsure why, but if I run chkdsk back to back, it will keep constantly find new errors every time. Also, the Chkdsk takes about 2 and a half hours to complete, and always gets stuck at 10% for most of that time. This is...
Plugged in my WD 'My Passport' 1TB HD, and instead of the usual prompts to do something with it, nothing happens at all now. I have noticed that it no longer has a letter assigned to it and when i attempt to initialize the drive, it tells me: 53681 "access is denied"... How do i gain...
The Players OS: Windows 8.1 Pro Laptop: Sager NP9150 Video Adapaters: Intel HD4000; nVidia GeForce GTX 670M Displays: Mobil PC Display; Samsung S24B300; LG 24MP56 Connections Samsung S24B300 - DVI LG 24MP56 - HDMI
I have a very peculiar issue; after using various disk imaging tools such as Macrium and Paragon, my boot partitions seem to be strangely corrupted. The effects of this corruption are: 1) Plain-text boot menu instead of the new graphical boot menu, 2) Long delays before the boot menu is shown,...
In the PC settings, under network, I turned on Find Devices and Content. This sets my network type to Private, which allows other devices on my network to see and share files, etc. This works fine, except that every time I restart Windows, that setting gets turned back off, and it reverts my...
Hello, So I installed the Windows 8.1 update today and installed the latest version of UxStyle. It seemed to work, but after a restart, I logged in and the UI was gone! I can still open the Task Manager and open programs though. What can I do to fix this? Please respond quickly :D Regards,...
I have a sony vaio vpcf12thx/h 64x 4gb I7 nvidia 310m I upgraded from w7 ult to win 8 x64 pro. Whenever I put a usb device such as a flash drive or an external hard drive in any of my usb ports they wont show up under computer, the autoplay doesnt pop up, nothing. I hae gotten the external hard...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook