Windows 8 and 8.1 Forums


Icons and names for USB flash drives incorrect

  1. #1

    Icons and names for USB flash drives incorrect


    On my windows 8.1 PC whenever I plug in any USB pen drive the thumbnail for the device is always an image of a Sandisk Cruzer Titanium as is the identity when I go to the safely remove hardware toolbar.

    The Sandisk probably was the first pen drive I plugged into the machine when new but surely it should be picking up details of subsequent devices or at the very least showing generic details.

    How can I rectify this?

    Cheers

    Baz

      My System SpecsSystem Spec

  2. #2


    Posts : 2,130
    Windows 8.0 x64
      My System SpecsSystem Spec

  3. #3


    Hi,

    I tried that and I tried removing all devices of the name Sandisk Cruzer but it didn't help. However I have noticed that the problem seems to be with storage devices plugged into my USB hub, that all get identified as a Sandisk Cruzer, yet when I plug them directly into to computer they get identified correctly.

    I have tried uninstalling and re-installing the hub but no joy.
      My System SpecsSystem Spec

  4. #4


    Posts : 216
    Windows 8.1 Pro with Media Center


    When you say 'uninstalling and re-installing the hub' do you mean full uninstall of it's drivers as well? The hub may be caching device names. Try identifying the exact hub (unplug it while in Device Manager, then plug it back in). Once you have the correct driver identified, run through the driver uninstall, remove the hub but do not plug it back in. Reboot and then plug in the hub. It should reinstall the drivers. See if it now identifies whatever the first device you plug in.

    If it does, it still may not fix your problem. The hub will report the first actual device and may never update each time a different device is plugged in.
      My System SpecsSystem Spec

  5. #5


    That USB has it's own id, if you reformat it to blank name it should show only as a regular one.
      My System SpecsSystem Spec

  6. #6


    I did a load of experimenting on this last night and have a bit more info

    Firstly the problem only seems to be affecting 2 ports of my 4 port USB hub.
    When I plug any pen drive in to the affected ports the icon displayed is that of a Sandisk USB Cruzer (which I have used in the past), also on the taskbar the pen drive appears to be identified as being attached to a Sandisk USB Cruzer rather than being a device in its own right eg.

    Sandisk Cruzer Ultimate
    - Eject 32GB Drive

    whereas normally you'd get

    Eject DT Ultimate G3
    - 32GB Drive

    Also when ejecting the drive does not disappear from My computer but is no longer exploreable (until unplugging/replugging).

    I have tried unistalling the HUB from device manager as well as uninstalling portable devices and drives.

    Something somewhere has somehow associated itself with these 2 ports and I am getting really confused as to what it could be, I have even considered a virus but I have done countless scans and found nothing.

    Help!!!

    Cheers

    Baz
      My System SpecsSystem Spec

  7. #7


    Are those two ports USB3 maybe ? Many computers have 2 or more USB controllers, I know mine has 3, one USB3 and two are for USB2.
      My System SpecsSystem Spec

  8. #8


    Quote Originally Posted by CountMike View Post
    Are those two ports USB3 maybe ? Many computers have 2 or more USB controllers, I know mine has 3, one USB3 and two are for USB2.
    It's an external 4 port USB3 hub
      My System SpecsSystem Spec

  9. #9


    Oh, it's external HUB, didn't realize that because internal are called HUBs too. What happens when you plug a pen drive directly to same computer's USB port where you plug that external HUB in ?
      My System SpecsSystem Spec

  10. #10


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    Suggest you try:
    1. Open regedit and go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer
      and delete the key called: DriveIcons
    2. Download: Drive Tools for Windows Cleanup Right click and run as Admin to clean up any orphan devices.
    3. Turn on Show hidden File in Folder Options to see is you have any autorun.inf file on the root folder of the USB, if so tnen delete it.
    4. After doing all that, Run: sfc /scannow from Admin prompt.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Icons and names for USB flash drives incorrect
Related Threads
I have a Nokia Lumia 1520 Win 8.1 phone. When I plug in my to USB to Micro USB (OTG) transfer lead and plug in a flash drive, I get no reaction from the phone. How do I use it to transfer photos, docs, etc. from the flash drive?
Fastest USB 2.0 Flash Drives? in Drivers & Hardware
Hi all, I like to keep a whole bunch of USB Flash Drives around for bootable Windows media, recovery, etc. I have a bunch of Patriot Xporter XTs and these were really fast and cheap drives. I can't seem to find them as cheap as I used to because they are discontinued. What are you guys...
Is it possible to sort a folder's contents with both File names and Sub-Folder names intermixed? I have projects in sub-folders, and 'support' files like this: projabc (sub-folder) projabc.txt (file) projabc.bat (file) amongst other projects. I would like all...
I wasn't sure what to name this thread because everything sounded so vague. But basically my icons are fubar! :'( More detail: Current Setup/programs that affected this issue: RDP Stardock Fences 2 Super Street Fighter 4 Arcade Edition Basically I RDPed into my home PC, tried to play...
Hi, I'm running windows 8.1 x64. When I insert a usb flash drive into my PC, it takes maybe over 2 minutes before windows "finds" it and has it appear in windows explorer. I have no idea what to do about this. I have the latest BIOS for my motherboard and I don't think there are any specific usb...
Yesterday, while I was trying to install an old driver for my printer/scanner from the manufacturer's DVD-rom, the screen blacked out, leaving only the mouse pointer was visible. Gradually the task bar appeared, and I could reboot the machine as usual. In the meantime, though, several of my hard...
Network name is incorrect in Network & Sharing
I have two wireless routers in my house and can see them correctly named when I choose which network to connect to. However when I connect to one of them the network name in the toolbar icon shows an old deleted network name and when I go the network sharing screen, I can also the the wrong name....
Eight Forums Android App Eight Forums IOS App Follow us on Facebook