Windows 8 and 8.1 Forums


Intel Management Engine inteface driver

  1. #1

    Intel Management Engine inteface driver


    I have been going crazy try to update my ASUS H81M-PLUS motherboard BIOS.
    ASUS is no help. Intel is no help.

    This might not be the right forum for this, but,

    I reached a point in the BIOS update (complicated) process where it now wants me to download the following driver
    for an Intel 4gen processor; (I5);

    Intel management engine interface driver!

    can't go any further without this driver!

    Can't find it! Can't find anywhere to get more info

    Help

    Tully

      My System SpecsSystem Spec

  2. #2


    Truly? Have you visited Intel Download Center and searched for this? Here's the link to the search engine results: Intel Download Center.
    All you need to do is to select your MoBo or - more general and easier - your chipset generation.
      My System SpecsSystem Spec

  3. #3


    Truly?

    Followed your suggestion & went to the Intel site found the Intel management engine interface driver.

    Tried to download it & said I had to download a Java Program first ?? What Java Program from where.
    Another step in a vicious circle.


    It seems to me that in this age of computer technology Asustek, Intel, Microsoft should have provided a simple means of updating the BIOS on a motherboard.

    I can remember in LESS technical times when updating a BIOS was a simple task.

    The computer industry should concentrate on this problem instead of creating another useless "FEATURE"

    The Old Fart

    Tully
      My System SpecsSystem Spec

  4. #4


    On most older MBs there was a way to update/upgrade BIOS version thru BIOS itself, that is not OS function, it's firmware written directly into BIOS chip. It's more complicated with UEFI bios updates. As far as I can see there's "H81M-PLUS BIOS 2001 and BIOS updater" program here : https://www.asus.com/Motherboards/H8...Desk_Download/ is that the one you were using / trying to find ?
      My System SpecsSystem Spec

  5. #5


    Quote Originally Posted by Tully View Post
    Followed your suggestion & went to the Intel site found the Intel management engine interface driver.

    Tried to download it & said I had to download a Java Program first ?? What Java Program from where.
    Another step in a vicious circle.
    Hmmm... That's strange as I have a fresh system install and have not installed Java so far. At the same time I had no problem with download the mentioned driver (just tested that).
    However if you are willing to get Java (it's also useful for other purposes), just download latest build from here - you'll need 32-bit version unless you're using 64-bit browser.
      My System SpecsSystem Spec

  6. #6


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
      My System SpecsSystem Spec

  7. #7

    Bios update


    I sat down & analysed the situation;

    1. I was already running Win 8.1 why would they recommend the download before the BIOS update?
    2. I started all over again, I downloaded the only BIOS update on the ASUS site that DID Not demand the update.
    3. Put the BIOS on a thumb drive.
    4. Went into the ASUS setup screen for BIOS update.
    5. Selected the thumb drive, It installed the new BIOS, held my breath!
    6. When it finished, I restated & IT WORKED!
    7 Problem solved!

    Thanks for all the help!

    Tully
      My System SpecsSystem Spec

Intel Management Engine inteface driver
Related Threads
In Device Manager I have an ! against Intel Management Engine Interface. In Driver Properties it says: This device cannot start. (Code 10) An invalid parameter was passed to a service or function. I have also seen errors related to this in a recent Perfmon report. I have tried to...
Reference: https://www.eightforums.com/bsod-crashes-debugging/54281-bsod-watchdog-restart-automatic-repair-loop-after-updates.html After solving some watchdog errors and getting all my windows updates, SteelSeries Engine is still failing me. It may have something to do with my drivers, but I'm...
Are these 2 drivers system-specific, or can I bypass the OEM's outdated drivers and grab the latest versions straight from Intel?
I seem to be in a loop while upgrading from a Pentium G840 to an i3770 K on an Intel DH61WW motherboard. It seems that I need version 8.x of Intel Management Firmware and I can't get to update past version 7.1.52.1176 According to this page, I need version 8.x to continue for updates to use...
Hi, i'm running the Windows 8 that the laptop(INSPIRON 15r 5521) came with, it's a brand new laptop (only around a month old ) and i'm running mcafee Security Suite as my antivirus. Over the past few dayss I've gotten the same blue screen error. It says 'Driver_IRQL_not_less_or_equal (Smb...
Hello, I am trying to install the Intel MEI (Intel Management Engine) for the Asus P9x79 WS motherboard. I have had no issues installing this on Win7 x64. However, when trying to install the drivers in Win 8 x64 from the Asus install CD, I get a OS not supported message. There are no drivers...
Intel AHCI driver in Drivers & Hardware
Is there any intel ahci drivers available? I have standard ahci driver installed and it feels quite slow compared to windows 7.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook