Windows 8 and 8.1 Forums

USB xHCI Compliant Host Controller driver not working

  1. #1

    Posts : 1
    Windows 8.1

    USB xHCI Compliant Host Controller driver not working

    Hi. First, im on a Lenovo Y510p Laptop. Yesterday, windows updated through windows update and when i logged into my computer, none of my usb ports were working. As in: My external mouse and keyboard were not connecting, they were working just before the update though.(they are new.) Device manager said there was an error with some driver so i tried to update, it said it was where it needed to be, so i uninstalled it, restarted the computer and it was fixed. Now, USB ports still not working, i have an error with this driver:

    USB xHCI Compliant Host Controller
    Under device status, it says:
    Windows cannot initialize the device driver for this hardware. (Code 37)

    The specified image file did not have the correct format, it did not have an initial MZ.

    Im not sure what other information i should give so here is some stuff that may help:

    When i press update driver it says that it is running the latest driver.
    Obviously, this driver is under Universal serial bus controllers in device manager.
    I use the laptop for mostly gaming.
    My mouse and keyboard WERE working before the update the same night.
    Any more info that could help just let me know, thanks so much.
    Attached Thumbnails Attached Thumbnails USB CAPTURE.PNG   USB CAPTURE 1.PNG   USB CAPTURE 2.PNG  

      My System SpecsSystem Spec

USB xHCI Compliant Host Controller driver not working
Related Threads
I installed Windows on to this computer while off line and used it for two weeks while off line and it worked perfectly. I then connected to the Internet and completed my work before shutting down. Upon start up it said do not shut your computer down while updates are being installed and...
Solved SM Bus controller driver Missing in Drivers & Hardware
Greetings to all, I have yet again some driver missing. This time it is the 'SM Bus Controller' driver missing. I have tried to use the sfc /scannow but no dice. Its telling me that all is good. I have tried to disable and uninstall completely then reboot my rig but still no dice. I...
The USB gaming mouse with LED for movement speed quit working. LED was off. USB Memory stick still worked. Device Manager showed that the Standard OpenHCD USB Host Controller had a yellow warning sign as shown below. Sadly, the driver was uninstalled and not examined first. 42512 The touchpad...
Every usb flash drive which works at other computers cannot be recognized unless is disabled at . Even though usb flash drives work by disabling it, the speed has become too slow in usb 1.1 mode. Is there any way to use usb flash drives without disabling Intel(R) 82801G (ICH7 Family) USB2...
Serial ATA Controller Driver... in Drivers & Hardware
...not installed. Any idea were I can find one?
I have tried everything that I know how to do to find this with no success. I have a dell precision m4600.
1454814549 When i updated from Windows 7 to 8 i found that this driver had a problem. Error Code 28 Can Anyone Help?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook