Windows 8 and 8.1 Forums


Windows 8 does not start with usb hub connected

  1. #1


    Posts : 109
    XP, Vista, Windows 7, Windows 8/ 8.1, Windows 10

    Windows 8 does not start with usb hub connected


    Hi there. Don't know in what subcategory to put this question, but I found this strange: When I have a powered usb hub connected, my windows 8 will not start. The same usb hub connected to xp or to windows 7 does not cause problems. But it does in windows 8. So I need to disconnect that hub and start windows 8 without it and connect it after windows 8 has booted. Said hub has two drives attached: 1 32GB and a 1 TB. How come Windows 8 cannot handle it? Thanks in advance for your help.

      My System SpecsSystem Spec

  2. #2


    Check BIOS for boot order.
      My System SpecsSystem Spec

  3. #3


    Posts : 109
    XP, Vista, Windows 7, Windows 8/ 8.1, Windows 10


    Thanks, CountMike. The first boot device is UEFI and the harddisk, 2nd is CD/DVD. So I don't know why there is that problem. I connected the 1TB usb drive directly into a usb plug on my machine. No difference. It just hangs at boot. Keyboard is frozen. Strange behavior.
      My System SpecsSystem Spec

  4. #4


    Quote Originally Posted by gallicbear View Post
    Thanks, CountMike. The first boot device is UEFI and the harddisk, 2nd is CD/DVD. So I don't know why there is that problem. I connected the 1TB usb drive directly into a usb plug on my machine. No difference. It just hangs at boot. Keyboard is frozen. Strange behavior.
    Realy strange, just couple of days ago I heard from a guy that had similar problem. He had a USB pen drive that used to have an OS on it, he even reformated it but I guess MBR stayed on it and he also could not boot with it connected. Must be some side effect of UEFI.
      My System SpecsSystem Spec

  5. #5


    Posts : 467
    Windows 8 Pro


    Read this....Microsoft acknowledges some USB items can cause UEFI systems to hang on boot..

    The only solution they have is to attach after boot...but it explains WHY this might be happening...

    Windows may hang during boot if a USB storage device is attached immediately after EFI POST
      My System SpecsSystem Spec

  6. #6


    Posts : 109
    XP, Vista, Windows 7, Windows 8/ 8.1, Windows 10


    Thank you again, CountMike, and also Wullail for the link. It explains that UEFI is involved. Maybe that will be fixed some day by Microsoft.
      My System SpecsSystem Spec

Windows 8 does not start with usb hub connected
Related Threads
Hi, I have a android smartphone which I use to run my android applications from my windows 7 dell laptop.This arrangement worked absolutely.I would connect my smartphone to my laptop through a USB and my computer would detect it and I could launch my app on smartphone whenever I want. ...
SOLVED: Had to to a format :drive /p:2, that is format with zeroing out the secondary flash drive which still had some boot loader, that activated randomly screwing up the system boot. Turns out the Asus Flash Erase is worth sh*t. Hello, I've got Windows 8.1 Pro x64 installed for a month now...
Hello, Logitech Gaming Software (latest, 8.51.5) is in my auto start list and everytime I boot it makes a device connected sound. I have the same on my Windows 7 x64 computer and it doesn't do that so Windows 8.1 x64 must be the culprit. I have looked in the Logitech help forums but they...
help i was having issues and i cleared the store cash and now windows 8.1 store dosent think i'm connected to the internet help :( i dont no what is wrong and i cant get it back on.
If a Windows 8.0 machine is part of an Active Directory Domain, what happens to the user/machine domain registration (user profiles etc). when upgrading to Windows 8.1? Are they maintained, or do you have to re-register with the domain? In this case, is it better to remove the PC from the domain...
I just bought a brand new computer and i am having trouble getting it to STAY connected to the wifi. It has windows 8 which i am not to keen on, and also know veery little about. It connects fine but after anywhere from 5-30 minutes it will go to limited connectivity. After this i disconnect from...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook