Windows 8 and 8.1 Forums

No Battery Indicator on my Acer

  1. #21

    Posts : 3
    windows 8 pro

    A few months after I last posted I noticed Acer had a bios update for my device. In this update I no longer have to use any device manager tricks, battery is recognized fine in windows 8 now.

    To anyone stumbling upon this in the future .. Check for bios update on Acer website :-)

      My System SpecsSystem Spec

  2. #22

    Posts : 2
    windows 8

    Quote Originally Posted by dcostalis View Post
    Same issue, found a fix:

    Go to device manager, right click and uninstall "microsoft compliant ac adapter"

    go to action>scan for new hardware.

    It'll find the battery and you wont even need to reboot :-)
    It works great! I had to extend it a little because when I clicked Action at the top, there was only Help there but when I clicked on something in device manager to expand it, I tried Action again and there was Scan for Hardware changes and after following the steps and selecting All devices, it worked--up popped my battery meter and it showed it was charging. The problem was finding this forum. I googled everything under the sun relating to Uninstalling A/c Adapter in device manager and finally found this after hours of looking. I found alot of Never uninstall the Microsoft A/C Adapter but nt what to do if you already did that. Why did I uninstall the A/C Adapter? Because I was having this no battery and no adapter icon on toolbar so i did not know if i was charging or not so i googled it and several sites said to uninstall the Microsoft A/C adapter. They should not be allowed to do that without finishing with the 2nd thing to do which is the above! Just had to say KUDOS to dcostalis for taking the time to post this solution. You are a life saver!!
      My System SpecsSystem Spec

  3. #23

    Posts : 1
    Windows 8.0

    Registered to thank "dcostalis" for FIX!

    I searched on-&-off for an answer to this question for 2 weeks before finding this forum. I have an Acer TimelineX. I have the same issue as others on this thread, no power icon in systray and it was grayed out (non-selectable), but also the "action center" flag was grayed out - this fix (dcostalis, response #8) brought both icon back to the systray. Good luck.

    I only did what they instructed:
    1. Go to device manager, right click and uninstall "microsoft compliant ac adapter"

    2. go to action>scan for new hardware.

    Now my computer layout was different but essentially the same, here are my 4 steps:
    1. Winkey+R, Device Manager
    2. Click right arrow under computer name where it reads "Batteries"
    I had two elements in this list: "Microsoft AC Adapter" and "
    Microsoft ACPI-Compliant Control Method Battery"
    3. I right-click deleted
    "Microsoft AC Adapter"
    4. I right-clicked computer name and scanned for hardware changes.
    BOTH icons came back in the systray instantly.
    and when I look at the notifications center, neither the power slider nor the action center slider is grayed-out, anymore.


    I do believe the issue is related to the "non-removable" battery in the Acer TimelineX. That is all I can figure. I agree that the machine is acting like it believes it is a desktop and therefore has no battery of which to report, so it leave the option non-selectable.

    Thanks for the fix.

    Note: I went through many regedit fixes and landed on many other forums. Many of the post were to old to apply to my machine hardware and OS. Even Microsoft support forums were void of specific solutions to this problem. This is the only solution that worked.

    I found a BIOS update that fixes this problem for the Acer Aspire Timeline 4830T, BIOS version 1.12 is the last option in the list at the Acer support website. it seems that the previous series of steps needs to be repeated unless the BIOS is upgraded. There is a Windows flash packages (much like a standard "installation package" that you double click.), you do not have to use DOS if that is not a comfortable environment for you. Just READ the readme - it's like four lines..
    Last edited by weaverpankaew; 27 Jul 2013 at 22:53. Reason: BIOS upgrade best option...
      My System SpecsSystem Spec

  4. #24

    Posts : 1
    Win 8.1

    [QUOTE=brummyfan;71227]You could try running sfc /scannow, may be some sytem files corrupted.

    This worked for my Toshiba s55t-b5260 ! My mouse and the battery were not detected after a windows 8.1 crash and now both are ok. Thanks a lot!
      My System SpecsSystem Spec

Page 3 of 3 FirstFirst 123
No Battery Indicator on my Acer
Related Threads
hi there, I have a Acer Aspire E1 570 laptop that I use for college, the laptop is less then 8 months old. For some reason recently it starting going dead at 40% battery charge remaining. I ran a powercfg -energy from the command prompt and it said that my batterys designed charge is 37000 and...
I have an Acer Aspire V5-472P laptop. My problem is that the battery indicator on the taskbar is malfunction. It stays "100%" at least until 2-3 hours and now the battery life ends at around 50%. Before this, it was around 20% then 30% then 40% and now 50%! It just keeps on increasing and I donít...
Hello, my friend got a new Asus Transformer T100 with Windows 8.1. The device was fine. We set up the Microsoft account and updated all the drivers, the firmware, Windows updates, as well as Windows Store app updates. But now the battery indicator is missing! It's not even on the pop-out when...
Problem with battery Indicator in General Support
Hello Everyone! I have windows 8 installed on my Acer Aspire TimelineX and everything is working great, but battery indicator keeps disappearing and showing up.I have already tried going to Device manager ----> action>scan for new hardware,but it disappears after I restart the computer.Any...
I just did a clean install of Windows 8 Pro on my 3 years old Asus Laptop. Everything seems to be working fine, except for the battery indicator and some Asus Fn keys.. The battery cannot be charged, it keeps showing 0% charging even after a few hours. I tried disabling and re-enabling the...
Hello, I've always enjoyed a battery percentage indicator on the taskbar. Where you can click or hover over & it will give the percentage left & approximate amount of time left on the battery. It appears that in Metro it will only show an image of a battery where you can kinda tell if it's...
Windows 8 Battery Icon not seen but once you install Conexant Audio Codec it shows up
Eight Forums Android App Eight Forums IOS App Follow us on Facebook