Windows 8 and 8.1 Forums

Asus z87 PRO motherboard AND Logitech G700s dongle problem

  1. #1

    Posts : 1
    Windows 8 Pro

    Asus z87 PRO motherboard AND Logitech G700s dongle problem


    I had some nasty problems with restarting my PC (Windows boot time doubled without any good reason). Suddenly Logitech's mouse was not working wirelessly. I still don't know what has gone wrong but after BIOS update computer did freeze in the Asus logo. I semi-accidentally removed mouse dongle from USB and BIOS suddenly launched normally. Weird! Now everything seems to be working correctly except the G700s dongle. Luckily BIOS is now safely updated to latest version(1802) from Asus site.

    Have anyone else had any similar issues?
    -BIOS lag
    -dongle not working
    -boot time doubling
    -Hard drive scanning and repairing... <- not sure if it's the same problem

    Sorry for my first messy forum post. I guess I did some BIOS updating few weeks ago also but nothing occured instantly. Still not sure about the source of the problem. Any ideas?

    btw. Two years ago someone had similar problems with Asus Sabertooth mobo when I search through Google.
    Last edited by janomies; 20 Apr 2014 at 06:53.

      My System SpecsSystem Spec

  2. #2

    Sydney, Nova Scotia, Canada
    Posts : 6,490
    Windows 10 Education 64 Bit

    Well first off, I personally wouldn't attempt a BIOS update with a wireless keyboard. It's just one more chance for something to go wrong. I've been using wireless Logitech keyboards and trackballs for years with no issues. All of mine use the Unifying receiver. They all work with the stock Windows 8.0/8.1 drivers. I have had to link the odd device to get it to work when I didn't use the dongle that came with it. I bought a new keyboard mouse combo and only wanted the keyboard. To get it to work with my trackball I had to run the Unifying software and par a new device. Maybe your mouse has become unpaired for some reason. It couldn't hurt to try repairing them. Also have a look in Device Manager under Human Interface Devices and see if Logitech Unifying USB receiver is listed. There should be a bunch of other Logitech entries there also.
      My System SpecsSystem Spec

Asus z87 PRO motherboard AND Logitech G700s dongle problem
Related Threads
Hi According to this link my old Asus P5K-E Wifi Delux board should be compatible: Windows 8 compatibility for ASUS P5K Deluxe/WiFi-AP AiLifestyle Series ATX - iP35 Motherboard model P5K DELUXE WIFI-AP However the Asus download site for this board does not list Win 8 as compatible OS -...
I have been getting too many BSOD every random number of times I restart Windows. I have an ASUS P8Z77-V Deluxe Motherboard and Windows 8 in UEFI mode and am using original stock speed using BIOS optimized defaults. I have all the ASUS drivers downloaded from the ASUS website rather than the...
I have a Intel Core Two Duo chip on and Asus p5b-vm se Motherboard. I have a simple question. Will it be able to run Windows 8? Anyone with those items running Win 8? Thanks
Solved Asus Motherboard Drivers CD won't run in Installation & Setup
I have an Asus P5QL VM DO montherboard in my homemade PC. This is an older system that I use for testing, so I put my Windows 8 install on it. Unfortunately, the Asus driver installation CD will not run in Win 8, and I am missing one driver which I am unable to locate anywhere. It is for the PCI...
I am planning to buy window 8 pro 32 bit. But before i buy i need to know if my system support window 8 and drivers for window 8 are available. My motherboard is ASUS M2N68AM Plus Motherboard ASUS - Motherboards- ASUS M2N68-AM PLUS On the website , there are drivers available for window...
Logitech M510 no scroll problem in Drivers & Hardware
Hello everyone, i've got a problem with my Logitech M510. When a user A is logged, user B can't use extra buttons and scroll wheel. When user A get unlogged, user B recover the mouse fully functionnal. No solution for me, latest drivers installed many many times, not solved. I've got a MS...
Anyone else having problems with USB Bluetooth devices getting lost on startup / reboot. I have a ASUS BT211 dongle that I have to delete the device and reinstall it. Works well otherwise. I had the same problem with a rocketfish dongle under windows7 64. Windows 8 64 Foxconn H67S 8 gig...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook