Windows 8 and 8.1 Forums

Razer Blackwidow Ultimate 2012 Bricked [Long post]

  1. #1

    Razer Blackwidow Ultimate 2012 Bricked [Long post]

    Hi everyone! Been a very long time since I've been on here, and I apologize, but here goes..

    I'll try and keep this as short as I can....

    • I done goofed, and my Black Widow Ultimate 2012 is kinda dead.
    • I tried firmware downgrading to 1.05 via firmware updater and killed it. I can't be too sure, but I think the version it was when it was working was 2.03. 2.03 is not available online anywhere; I think it only comes with Razer Synapse
    • When attempting to update the firmware (1.05, 1.07 and 1.08 I have tried it with) the only way it detects the keyboard is by pressing the Fn key. If I hold the Fn whilst updating, the update process will loop forever, and if I let go, it doesn't appear to do anything. It updates. or says it does, and then goes to the "congrats you updated" screen but the keyboard doesn't light up or respond in anyway, and the device will no longer be detected. Rebooting proves this, as the keyboard remains dead.
    • The keyboard as it stands, can only be picked up by windows as a "razer bootloader", and that is when I press the Fn key. Otherwise it stays completely undetected. All existing driver software also do not pick up the keyboard at all (BWU 1.05 drivers, 1.03 drivers and Synapse 2.0)
    • Upon reboot, devices screen either reads as Razer bootloader again, nothing, or an unknown USB device (Device Descriptor Request Failed) No fix for that, other than to unplug and replug the keyboard in again and let it go to the Razer bootloader.)
    • So basically, through the process of using my eyes, it looks like the problem is the updater itself. Regardless of version (1.05, 1.07 and 1.08) the update appears to actually skip over some parts of the firmware update, and then go to the verification screen/completion screen. The keyboard is essentially wiped, but gets appears to get no incoming firmware, thus the brickness.
    • To make this a bit clearer, the firmware update only works if the keyboard is detected in windows as Razer Bootloader. Once the update "completes" the bootloader actually dissapears, complete with the windows sound when a USB is unplugged; and the keyboard remains dead until another tap of the Fn key brings back the bootloader, also with windows noise acknowledging a USB has been detected.
    • Going off peoples suggestions online; "install driver v1.03 and firmware v1.05, have keyboard in bootloader mode and update it via device manager > [here the suggestion notes that you can use the file, "RzrBtLdr.inf" in the bootloader folder and manually install drivers] > bootloader then gets a ! icon next to it, and apparently synapse will then complete the update of the keyboard."
    • However, although I can install "something" using the RzrBtLdr.inf file, updating the drivers for the bootloader via device manager ends with :

    "Windows found driver software for your device but encountered an error while attempting to install it.
    This device cannot start. (Code 10)

    • I don't think thats a good sign..

    I'm really really hoping someone on here has any ideas or a fix that I haven't tried yet.

    My bottom line; I need something to install firmware onto the keyboard, but Synapse doesn't pick it up, and there aren't anymore firmware updaters to use. There might be a problem with windows not properly utilizing the updaters, or there might just be nothing else I can do with the keyboard. But the fact that Fn/Razer Bootloader still works suggests it CAN be fixed.

    (I have also contacted Razer about this but we'll see if they even reply, and I bought the keyboard 2nd hand so I'm ****ed if they tell me to RMA)

    I do have usbpcap and wireshark installed, and I THINK I've managed to properly record the action of the firmware attempting to update the keyboard; I have a pcap file saved if anyone wants to take a look at it, but I am NOT familiar with the workings of usbpcap so I may have recorded something else entirely.

    Click image for larger version This is where it currently sits.

      My System SpecsSystem Spec

  2. #2

    Just resolved this same issue today after 2+ hours of trying to find a solution. While I do not know if you will be able to successfully downgrade (still trying to work that bit out for myself) I found that reinstalling Razer_BlackWidow_Ultimate_FirmwareUpdater_v2.05.03 from Download Razer BlackWidow Ultimate Keyboard Firmware Updater 2.05.03 for Windows XP/Vista/7/8 x86/x64
    fixed an otherwise bricked keyboard. Still have to put up with the razer software but its better than 200dollars down the drain.

    *not trying to dig up a dead post just aiding other owners in their google searches*
      My System SpecsSystem Spec

Razer Blackwidow Ultimate 2012 Bricked [Long post]
Related Threads
Just as the title says Hi guys I got a new mouse a couple of days back, it's one of those fancy Razer mouses with 12 buttons on the side that is used for gaming and stuff. I have an issue when I try to use usb 3.0 instead of 2.0 ports. ( my tower only has like 2 2.0 ports so I try to use those...
Microsoft Launches Recovery Image to Fix Bricked Windows RT 8.1 Tablets
Does anyone know how to stop connections from attaching themselves to a network - or at least that's what I think is happening! Please bear with me while I explain and illustrate. The Problem (from my perspective): I have been having problems with my computer(s) for about six months now to a...
Solved Razer Nostromo programming? in Drivers & Hardware
I've got a Razer Nostromo on my main PC that I use for gaming, but after the Windows 8 install, the Razer programming software won't recognize the pad. It shows up correctly under devices, but the programming software gives the error of "No Razer Nostromo Connected. Application will close now." ...
Read more at source: AnandTech - Samsung Laptops Bricked by Booting Linux Using UEFI
Solved Razer nostromo isn't lit in Drivers & Hardware
Hello, I recently plugged my razer nostromo in and the backlighting won't come on. I have the latest driver (2.05) and the backlighting did work before this. Thanks, -Rick
Razer Blackwidow Keyboard in Drivers & Hardware
Since using Win 8 CP I have noticed my keyboard often misses the letter "e" and double types other letters randomly. I am not sure if it is a win 8 problem or coincidence that this has happened since using Win 8.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook