Windows 8 and 8.1 Forums


2gb Usable ram on 64bit Windows 8.1

  1. #1

    2gb Usable ram on 64bit Windows 8.1


    Hello Everyone,

    I have 2x2GB ram & installed Windows 8.1 64bit Update 1 while usable ram is just 1.9gb. Can someone please let me know what is the problem?

    Please check screenshots.
    Attached Thumbnails Attached Thumbnails Capture1.PNG   Capture2.PNG  

      My System SpecsSystem Spec

  2. #2


    Posts : 22,577
    64-bit Windows 10


    Hello Masty,

    Do you have an integrated graphics chip?

    If so, then that would most like what is using the other amount of RAM. Integrated graphics will have a portion of RAM dedicated for it's as set in your BIOS.

    Hope this helps,
    Shawn
      My System SpecsSystem Spec

  3. #3


    I don't have integrated graphics cards.

    All were fine, it happened when I installed Update 1 of Windows 8.1 64bits
      My System SpecsSystem Spec

  4. #4


    Posts : 22,577
    64-bit Windows 10


    In your Task Manager screenshot, it shows that 2GB is reserved for hardware.

    Even if you don't use integrated graphics, if you motherboard includes that feature, then double check your BIOS/UEFI settings to see if any RAM was set to be used by graphics or any other hardware.

    In addition, double check to make sure that the Maximum memory box is unchecked like in step 4 of the tutorial below.

    Memory - Set Maximum Amount Used by Windows - Windows 7 Help Forums
      My System SpecsSystem Spec

  5. #5


    My motherboard is Asus P7P55 LX & It doesn't have integrated GPU also my processor is Intel Core i5-750 which doesn't have integrated gpu too.

    I tried all steps in above mentioned link, but it didn't work. My desktop is damn slow & ram usage is like 90% all the time
      My System SpecsSystem Spec

  6. #6


    Posts : 22,577
    64-bit Windows 10


    In that case, as a test, check the Maximum memory box, select 4096 for 4GB, click on OK, and restart PC to see if that may help.
      My System SpecsSystem Spec

  7. #7


    I have tried both methods but still same issue

    I updated nvidia driver & Windows 8.1 Update 1 today & problem started.

    My specs are here.
    Intel Core i5-750
    Asus Motherboard P7P55 LX
    Nvidia 9800 GT 512MB
      My System SpecsSystem Spec

  8. #8


    Posts : 35
    Windows 8.1 pro 64 bit


    The situation you describe is usually the result of bent cpu pins, or a poorly seated processor. The fix seems to be to pull and re-seat the processor, carefully straightening any bent pins while you have it out. Check this out:

    Windows 7 x64 says RAM 4 GB but 2 GB usable [Solved] - Gigabyte - Motherboards
      My System SpecsSystem Spec

2gb Usable ram on 64bit Windows 8.1
Related Threads
Hi I have been refurbishing an old computer lately and have almost finished it But I have hit a problem with the RAM I can only use 3GB out of the 4GB I have installed The computer is manufactured by HP though the motherboard was made by ASUS
Solved Only 3.5gb of 4 gb ram usable? in General Support
i have 32bit win 8.1 with 4 gb ram but it says only 3.50 gb ram usable??? WHY???:rolleyes::huh:57776Please help....
Solved 8GB RAM but only 3.35GB Usable in Drivers & Hardware
Hello, I have 8GB of ram on my computer and I have 32bit Windows 8 OS. But my computer says "8 GB (3.35 GB usable)" why is this? I am struggling to solve this and appreciate if anyone could solve this immediately as I have some high priority work to deliver! Thanks, -Srujan
Hi everyone, recently i installed a windows 7 alongside with windows 8. However, the booting screen is black (DOS mode), while it's blue (somewhat Metro-like i guess) for my bro. This is not really an issue but i'd like it to be blue with usable mouse. As stated above, it's not really an issue but...
Hi, When I updated it left me with an old windows folder can I delete this or dose this have to stay there? Thanks
does windows 8 32bit support all 4 gb ram or only 3.5 is usable ????
Eight Forums Android App Eight Forums IOS App Follow us on Facebook