Windows 8 and 8.1 Forums


Disk Management messed up my partition table!!!

  1. #1

    Disk Management messed up my partition table!!!


    Hi all,

    I had a nice working multiple booting system on my Mac Book Air with the following partition table:

    Partition 1: Primary - HFS - Bootloader (set as active)
    Partition 2: Primary - NTFS - Windows 8
    Partition 3: Extended partition (rest of my hard disk was this extended partition containing logical partitions as following)
    Partition 4: Logical - HFS - Mountain Lion
    Partition 5: Logical - EXT4 - Debian
    Partition 6: Logical - EXT4 - Ubuntu
    Partition 7: Logical - NTFS - DATA
    Partition 8: Logical - HFS - Snow Leopard

    Note: Partitions 4-8 are inside Partition 3 (extended).

    Now as I had some troubles hibernating Windows 8, after reading that I have to set Windows partition as active, I went ahead and used Disk Management program and set Partition 2 as active (before it was Partition 1 as mentioned above).
    And bammm, Partitions 4, 5, 6 and 7 are lost!!!! This is so bad, Microsoft! I just wanted to make a partition active, that's it... and now my other operating systems and more importantly the Data I had on partition 7 is gone!

    Can someone please help me? Are there any chances to get the partition table data back? I have another system that has Linux and Mac OSX if that's needed for recovery. Please help.

    P.S. The weird thing is that, as a result of this, all extended partitions seem to be affected except the last one (Partition 8) and I can confirm that it boots and I have a functioning Snow Leopard there... but Partitions 4, 5, 6 and 7 are gone like they never existed before!

      My System SpecsSystem Spec

  2. #2


    Posts : 2,130
    Windows 8.0 x64


    Windows 8 uses GPT. I suspect your system uses MBR partition scheme. I'm not familiar with Mac. You may have better luck on a Mac oriented forum. If you have backups then you may be able to fix the corrupted data once the partition table is restored.. if it can be.
      My System SpecsSystem Spec

  3. #3


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    Microsoft had nothing to do with it. You are running a Mac with Debian, Ubuntu & Windows. Any of those three could be the culprit. You would be better to run Ubuntu & Windows inside a Virtual Machine, then as an actual image on your Mac.
      My System SpecsSystem Spec

  4. #4


    Yes, there are chances of recovering data from Mac missing partition efficiently by using reliable and professional recovery tool.
      My System SpecsSystem Spec

Disk Management messed up my partition table!!!
Related Threads
Hi, I have a laptop with Windows 8 installed in a 256Gb SSD. There's a 32Gb recovery partition whose purpose is to recover the drive to factory install. Since I already imaged this recovery partition to an external drive I would like to delete it and merge it to the main C partition to increase...
Restore partition table? in General Support
(copied from another forum location) Okay, so long story short I recently tried installing Ubuntu dual boot with my Windows installation as I had done with a previous system. I somehow failed to notice I had whole disk selected rather than the option for partition. Well. Obviously it wiped my...
Perhaps someone here can help me troubleshoot this problem? I did a brief search for this same issue but i could not find anything matching on these forums. Ive long been an XP user, just purchased a new desktop with 8.1 and a 2TB HDD this week. I was partitioning some drives to organize...
Can I delete / merge the Recovery Partition into the EFI System Partition? 34912
Hi, I had Windows 8.1 installed for quite some time and wanted to go back to 8 today until the real update rolled out. I had a system image stored with everything I wanted setup correctly. Unfortunately for some reason I couldn't restore form a system image through Windows 8.1. I opened the...
I need some guys, i brought an HP Pavilion G6 and it comes with an GUID partition table (GPT), EFI and Secure Boot. However i need an MBR partition table, so i tried disk managerment but the option "convert to mbr" is greyed out and when i run the "diskpart - list disk - select disk 0 - convert...
Encountered this problem when trying to install windows: I couldnt install windows in C ,neither to format that partition because of this message and an error code 0x0000 smth... while attempting to format the C. I could only manage to instal windows after deleting all of the partitons???? On...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook