The Hp deskjet 5740 printer is on a TP-link printsever. I add the printer trough the wizard, but he is not listed under devices. I can choose to print to it but W8 says 'printer not ready', I run the wizard twice, but no success: however when I do 'contr+P' the 2 printers are listed but keep giving error on print command.
On my W7 laptop then this printer becomes 'offline', so i needed to reinstall the driver to work again on that laptop. So the printer is fine. The problem must be somewhere in the home-group or something like the adobe-reading printer bug.

I also have a problem whith a Hp photosmart B109n wireless : W8 sees it but I 'm unable to ad it, when I run the w7 driver from Hp website I get an 'network' error when i try to install the printer. Works fine under W7 and xp. In control panel I see it as an 'other device' and driver missing.

I use a home group, but do not share the printers. I use W8 32bit .

I tried W8 64bit but had no succes in installing NEC pinwriter P20; HP deskjet 5740, D2660, 815c, I did not find a video driver for my MSI VR610, so I had to install 32 bit.