Windows 8 and 8.1 Forums


USB-connected hard drive no longer recognized

  1. #1


    Posts : 3
    Windows 8.1

    USB-connected hard drive no longer recognized


    Hello all,

    I'm hoping I can get some help with this: A few hours ago, I connected a hard drive to my PC. I was able to read/write to it just fine. In fact, I've used it various times in the past.

    I just tried connecting it again now, and the drive is not showing up on Windows 8.1 at all. It's not being detected.

    I connected the drive to a Mac to see if it was the drive, but it wasn't: the Mac was able to read it just fine.

    I've had a similar situation in the past with this machine, where my iPhone was, seemingly out of nowhere, no longer recognized by the system. Plugging it in would register on the phone, but the PC wouldn't acknowledge its existence.

    I'm completely at a loss as to why this can be. Other drives connect to the PC just fine (in fact, I have another one connected now, as I write this, backing up some data). Any help is appreciated.

    TIA.

    EDIT: I hope this is the right forum for this question. It sounds like it might be a driver issue, hence my guess. If I'm wrong, my apologies.

      My System SpecsSystem Spec

  2. #2


    Posts : 446
    Win 8 64-bit


    Most people seem to use laptops now-a-days, so I'm not sure whether this will apply to you.

    On my desktop with a USB 3.0 PCI-E card installed, after installing both Windows 8 and 8.1 it done the same as you. I.E. When I connected an external hard drive via USB it initially worked fine, but later it suddenly stopped working for no reason. I can't remember exactly what error it showed in Action Centre > Reliability Monitor, something along the lines of Video Hardware Error, LiveKernelEvent.

    To cure it I disconnected the power connector to the USB PCI card for about 10 seconds, reconnected it and after booting the problem was cured (until I re-installed Windows about a year later, where exactly the same thing happened and I had to do the same thing again). So if you are using a desktop PC with a PCI USB card installed, try that.
    Last edited by ARC1020; 24 Feb 2014 at 22:25.
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Windows 8.1


    I have a tower I built recently, so I'll definitely be giving that a try (probably tomorrow evening, as I need to work tonight). I'll keep you updated. The USB ports aren't through a PCI card, they're on the case (Fractal Design R4), connected to the motherboard (Gigabyte Z87x-UD4H).

    Thanks!
      My System SpecsSystem Spec

  4. #4


    Did you try on the USB ports directly on the MB behind the case, front ones can make problems.
      My System SpecsSystem Spec

  5. #5


    Posts : 3
    Windows 8.1


    Yep, tried both. Nothing doing. What's odd is that the same thing happened with my iPhone a few weeks back, and now I can't back up the sucker. I'll take it this isn't a common issue, but is this a sign of anything wrong going on with my PC?

    NOTE: The issue with the hard drive itself, however, was resolved by reformatting the drive. (I used the Mac to format the drive to Fat32.) I'll be trying the aforementioned method, though, for the iPhone itself.
      My System SpecsSystem Spec

USB-connected hard drive no longer recognized
Related Threads
Hello.. Tonight when I plugged my LG G-Pad into my laptop it made the usual audible tone but is now no longer visible. Worked fine about 2 days ago, now nothing.. Interestingly enough it works fine on my desktop (Win 7) and my office computer (also Win 7), but all the sudden it doesn't appear...
hard drive not recognized in General Support
when plugging in my seagate freeagent hard drive i get the message "USB device not recognized. I have been to device manager and it appears as "unknown USB device (device descriptor request failed)". I have tried uninstalling it and reinstalling, checked for new drivers/updates. no luck any help...
I built my computer a couple weeks ago and am running windows 8.1. I currently have a 128gb SSD and a 1tb internal hard drive (WD Caviar Blue) I obviously used the ssd to boot windows and currently windows is detecting my 1tb hard drive but it is not usable. I have tried diskpart commands to...
I have been running my laptop (Thinkpad W530) with two hard drives for about a year (Main SSD and secondary HD) with no problems until all the sudden this morning when I turned my laptop on, it wouldn't boot windows, instead it went to a black screen that said main HDD error and to press enter to...
Solved DVD Drive No Longer Recognized in Drivers & Hardware
Hi all. I have a TSST 208DN DVD drive installed in a Win 8 Pro Toshiba C855 machine. I am no longer able to use the drive and could use your advice and assistance. The problem began with my always having to reinstall the drivers upon reboot. I found a solution, or so I thought, that advised...
Hello there, I've run into this weird problem wherein my Windows 8 laptop has suddenly seized to recognize not only the WiFi signal of my own router, but also any WiFi signals at all. Airplane mode is turned off, I restarted the PC, I checked the Settings menu only to find it doesn't have a WiFi...
Hello, I'm about to loose my mind.. So today I've pluged-in an Arduino device and everything gone great until for some unknown reason my computer just ignored the device and started to pop-up "USB device not recognized" the same device works perfectly fine in my other computer.. after trying, I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook