I've owned this Blue snowball for a few years now. And I've had it connected to 3 different PCs including this one. Problem is, with this one it no longer wants to work except every now and then. I am currently using a Gigabyte G1Sniper Z87 with a Intel I7 4770k, my last pc was a AMD FX-6350 in a AsRock 990FX Extreme4.

I'm also running Windows 8.1 on both.

Pretty much what is going on is the Mic is recognize under Devices and Printers as Blue Snowball but it has a Yellow Triangle next to it. If I right click and run Troubleshoot i get this message.

USB Composite Device is and older USB device and might not work with USB 3.0

Plug the device into and available USB 2.0 port, and click Next. Otherwise, click Cancel.

I don't have the device plugged into a USB 3.0 slot, in fact I've tried every slot I have. Front ports, back ports, I even tried the 2 on my keyboard and I get the same thing.

Now if I go into Device Manager and click on the Audio inputs and outputs tab, It doesn't show up in there. In the Human Interface Devices tab it shows up as, HID-compliant consumer control device with a Yellow Triangle. If I go into properties. In the General tab there is a Device Status box and inside the box it says, "No drivers are installed for this device."

But if I go down into the Sound, video and game controllers Tab. It shows up as USB Audio Class 1.0 and 2.0 DAC Device Driver, without a Yellow Triangle. If I right click it and go into Properties, under the same Device Status box it says, "This device is working properly."

I truly don't know what to do anymore.