Windows 8 and 8.1 Forums


USB 3.0 ports don't recognize USB 3.0 devices

  1. #1


    Posts : 28
    Windows 8 Enterprise x64

    USB 3.0 ports don't recognize USB 3.0 devices


    I have recently bough a new PC. Now that everything is put together and installed I am facing only ONE problem.

    I own an Adata Nobility NH13 External HDD which is USB 3.0. When I plug it into any USB3.0 port using a USB3.0 cable, the drive does not show up in My Computer, nor in Device manager, regardless if I use the Front or Rear USB3.0 ports.


    The USB2 ports work just fine with it but what is the point in having a USB3.0 device if you don't use it the way you should...

    If I plug in USB2 devices in the USB3.0 ports the work great, and even if I connect the ExtHDD with a USB2 cable it does work.

    Now, the first thing you would think is that the USB3.0 drivers are missing but in the Device manager, unser USB controllers, there is a Intel(R) USB 3.0 eXtensible Host Controller-0100(Microsoft).


    If anyone has any suggestions, any help is greatly appreciated...

      My System SpecsSystem Spec

  2. #2


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Install 3.0 driver from motherboard site or Intel.com.

    Update motherboard bios to latest. Update 3.0 firmware to latest, if they offer that at all.

    Try a different cable if those didn't do the trick. 1st one should though.
      My System SpecsSystem Spec

  3. #3


    Posts : 28
    Windows 8 Enterprise x64


    Quote Originally Posted by MasterChief View Post
    Install 3.0 driver from motherboard site.
    Well I would but there are only 3 Hotfix windows updates, which I have already installed.
      My System SpecsSystem Spec

  4. #4


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Which motherboard? I will find the download for you.
      My System SpecsSystem Spec

  5. #5


    Posts : 28
    Windows 8 Enterprise x64


    Quote Originally Posted by MasterChief View Post
    Which motherboard? I will find the download for you.
    Its Gigabyte GA-Z87-HD3... Any btw, you could have looed at "My System specs" at the end of my posts
      My System SpecsSystem Spec

  6. #6


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Quote Originally Posted by desmond13 View Post
    Its Gigabyte GA-Z87-HD3... Any btw, you could have looed at "My System specs" at the end of my posts
    You recently bought a new pc. That could have been after you made your specs, no?

    Here ya go: http://download.gigabyte.us/FileList/Driver/mb_driver_intel_usb3_8series.exe

    then install latest bios which specifically needs to be installed after that USB 3.0 update, as Gigabyte's site claims:

    http://download.gigabyte.us/FileList...87-hd3_f7d.exe
      My System SpecsSystem Spec

  7. #7


    Posts : 28
    Windows 8 Enterprise x64


    When I run that I get error "This computer does not meet the minimum system requirements for installing the software"
      My System SpecsSystem Spec

  8. #8


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Extract it. Open Device Manager.

    Right click on USB 3.0. Update driver software. Browse my computer. Let me pick. Have disk. Browse.

    Navigate to where you extracted it. IntelUSB30\Drivers\xHCI\Win7\x64

    Double click on iusb3hub.inf then click ok. Continue installing until done.

    If that gives any problem, then try the other .inf.
      My System SpecsSystem Spec

  9. #9


    Posts : 28
    Windows 8 Enterprise x64


    It says "Windows has determined that the driver software for your device is up to date"
      My System SpecsSystem Spec

  10. #10


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    That means you didn't follow instructions well. It will never say that when specifically telling it to install from a specific .inf file.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
USB 3.0 ports don't recognize USB 3.0 devices
Related Threads
Hi all, new user here :) To the Admins/Mods: Thanks for running such a great forum! To get to the point... Like the post title says, my HP all-in-one computer (Win 8.1) won't recognize any USB devices unless I have them plugged in during boot-up. This can be quite frustrating when I just...
42031 Whenever I try to connect my flash drive, phone or digi cams. It can't detect anything then I saw this in device manager, is this the culprit? Please give me solutions.. I can't do my project without transferring files
I'm having an issue where if my USB devices are plugged in when i start my computer they are fine. but if i try to plug in a thumbdrive after it's already been turned on it won't recognize it. nothing. Just Ran the SFC /scannow and i don't know what to make of it. any help would be appreciated....
Hi, I am having problems with USB 3 devices disconnecting and reconnecting all the time when they are plugged into the Esata ports on the back of the motherboard in my sig. The USB 3 devices work ok in the normal USB 2 and 3 ports on the motherboard but I am not sure why they are not working in...
Solved Problem with usb ports/audio ports in Drivers & Hardware
I have a problem with my front usb ports/audio ports, a couple days ago I replaced my radiator and unplugged the cord for the front usb ports but it went back in fine and ever since then I would have my headphones plugged in but whenever I took out something from the usb port the headphone/audio...
Hey all so I have forwarded some ports on my router with Airport Utility (NAT port forwarding), but using cmd netstat -n the ports I forwarded aren't listed and using online port checkers confirms they are closed. I added exceptions to my firewall (even though it is off), and windows defender is...
After upgrading to 8.1 all of my previously listed devices are no longer listed under devices... in fact there are no devices listed. I can also not add a device. If I look in device manager they are listed there and if I go to print the printer shows up and I can print. The screenshot below...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook