Windows 8 and 8.1 Forums


USB 3.0 ports don't recognize USB 3.0 devices

  1. #11


    Posts : 28
    Windows 8 Enterprise x64


    Well, if I do what it says, and i click Have disk, and point to either on of the .ini files it says that if didn't find any compatible drivers

    And I don't think that the drivers are the problem, as Win8 has native support for USB3.0 and my Z87 chipset has an integrated USB3 controller

      My System SpecsSystem Spec

  2. #12


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Quote Originally Posted by desmond13 View Post
    Well, if I do what it says, and i click Have disk, and point to either on of the .ini files it says that if didn't find any compatible drivers

    And I don't think that the drivers are the problem, as Win8 has native support for USB3.0 and my Z87 chipset has an integrated USB3 controller
    Then install from here instead: IntelUSB30\Drivers\HCSwitch\Win7\x64\iusb3hcs.inf

    or get the driver from Intel.com.

    Yes, driver is the problem.
      My System SpecsSystem Spec

  3. #13


    Posts : 28
    Windows 8 Enterprise x64


    Now I have installed that and ma ish drivers don't work at all and u cannot use my mouse abd keyboar no more
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
USB 3.0 ports don't recognize USB 3.0 devices
Related Threads
Hi all, new user here :) To the Admins/Mods: Thanks for running such a great forum! To get to the point... Like the post title says, my HP all-in-one computer (Win 8.1) won't recognize any USB devices unless I have them plugged in during boot-up. This can be quite frustrating when I just...
42031 Whenever I try to connect my flash drive, phone or digi cams. It can't detect anything then I saw this in device manager, is this the culprit? Please give me solutions.. I can't do my project without transferring files
I'm having an issue where if my USB devices are plugged in when i start my computer they are fine. but if i try to plug in a thumbdrive after it's already been turned on it won't recognize it. nothing. Just Ran the SFC /scannow and i don't know what to make of it. any help would be appreciated....
Hi, I am having problems with USB 3 devices disconnecting and reconnecting all the time when they are plugged into the Esata ports on the back of the motherboard in my sig. The USB 3 devices work ok in the normal USB 2 and 3 ports on the motherboard but I am not sure why they are not working in...
Solved Problem with usb ports/audio ports in Drivers & Hardware
I have a problem with my front usb ports/audio ports, a couple days ago I replaced my radiator and unplugged the cord for the front usb ports but it went back in fine and ever since then I would have my headphones plugged in but whenever I took out something from the usb port the headphone/audio...
Hey all so I have forwarded some ports on my router with Airport Utility (NAT port forwarding), but using cmd netstat -n the ports I forwarded aren't listed and using online port checkers confirms they are closed. I added exceptions to my firewall (even though it is off), and windows defender is...
After upgrading to 8.1 all of my previously listed devices are no longer listed under devices... in fact there are no devices listed. I can also not add a device. If I look in device manager they are listed there and if I go to print the printer shows up and I can print. The screenshot below...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook