Windows 8 and 8.1 Forums

Cannot safely eject

  1. #11


    Posts : 17
    Windows 8.1


    Done that and opened a few times, still no luck. But thanks for your efforts.

      My System SpecsSystem Spec

  2. #12


    Posts : 2,130
    Windows 8.0 x64


    When you run on command line this is all you see

    Click image for larger version

    See how to open an administratie command prompt in Tutorials.
    Also see Path environment variable.

    Your drive letters may vary. For a USB specify the drive letter on command line. If your USB drive letter is x then do


    sync x <press enter key>

    in the command window

    Some things just can't be done from the gui.

    The "sync" only lasts until the next file access on that drive, so run sync and when it says the drive is flushed, pull the USB out.

    Edit: if you can't get it to act as described, post because there may be some issue on your system.
      My System SpecsSystem Spec

  3. #13


    Posts : 17
    Windows 8.1


    Hey sorry man I ended up putting this down for a while. OK I plugged in my external drive and run command and it just says C drive; doesn't seem to register the USB drive.
      My System SpecsSystem Spec

  4. #14


    Posts : 17
    Windows 8.1


    If I leave my external drive plugged in and turn off the computer I can't boot up when I turn it on again and the only option is to turn the computer off and on at the powerpoint. Quite strange. Anyway I've decided to leave the external drive in and use sleep mode instead of turning the computer off. Thanks for your replies MilesAhead.
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
Cannot safely eject
Related Threads
Solved How do I eject an eSATA drive? in Performance & Maintenance
I have an external eSATA drive in a Nexstar case connected to one of the eSATA ports on the motherboard (Asus P9X79-LE). When I power the drive on, it is detected and the volume automounts, but when I have finished with it (I use it for backup) Windows appears to have no way to eject the volume...
This shortcut is different than the "Safely Remove Hardware and Eject Media" icon in the system tray. Is it possible to have a shortcut which opens this drop down menu, which you get when you right click of the system tray icon? Thanks!
Up until today, whenever I had a USB flash drive connected and I wanted to remove it I would click the icon in the System tray for "Safely remove hardware and eject media" and then my drive letter would be shown and I'd click on it to safely remove it. I am running Windows 8.1 and today when I...
Solved Cannot safely eject SD card? in Drivers & Hardware
Recently when I tried to eject SD card it always says something is still using it. But there is no program running that's using it as far as I can tell. :confused: I tried several things, no help: Turn off AutoPlay in Control Panel OpenedFilesView - View opened/locked files in your system...
I have a virtual CD on my computer but when i right-click the eject button is faded grey and won't work. How can I force eject this? Please help it's decreasing performance!!!
can't eject virtual CD in Drivers & Hardware
I have an HP printer that has installed a virtual CD with the driver. The software won't install, but the printer works fine regardless, problem is, I can't eject the virtual CD no matter what I do. Any way to force this thing to eject?
http://i47.tinypic.com/2ef7yp5.png Help? thanks.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook