Windows 8 and 8.1 Forums

W8.1 Cannot read physical or mounted DVD's

  1. #1

    Posts : 5
    Windows 8.1 Pro and Media Center

    W8.1 Cannot read physical or mounted DVD's

    I upgraded my system from W8 pro&mc to W8.1 pro&mc through Store and I am now unable to read DVD discs. The problem occurs with both Liteon iHas 124b SATA drive and virtual mounted ISOs when mounted with the OS's internal mounting thingy. They have both worked before but at some point stopped working after the OS upgrade.

    Physical drives:
    The Liteon drive should be working correctly, it is showing up correctly in device manager and explorer and is able to burn DVD's with 3rd party programs, but will not read DVD's. When I insert a commercial or self-burned DVD the drive image in explorer changes from DVD to DVD-ROM, so at some level the drive and OS do recognize the disk. When I double click (or right click->open in explorer) the DVD drive image to browse the content, it will prompt me to insert media and ejects the drive. 3rd party playback software is unable to play the media and CMD will not navigate to the content either.

    Virtual drives:
    When I try to mount .iso files that have worked for me before, I get the error "There was an error mounting the image". But again the system recognizes the mounted file at some level, because it adds a new virtual drive to My Computer and flags the iso file as being in use by the system. However as with the physical drive, I cannot access the contents of the ISO. I have to use the eject button of the virtual drive if I want to edit/delete the iso file and get rid of the virtual drive, as I would if the image mounted correctly. There has never been a 3rd party img-mounting software on the system.

    What I have tried after searching the web with no results:

    - Updated OS&drivers / flashed firmware of everything to the latest versions
    - Used multiple DVD's with different media types (movies, games) and multiple iso files for testing
    - Tried mounting from different locations and HDD's
    - Checked the iso files are not flagged sparse
    - Reverted autoplay options to "always ask"
    - Checked the installed programs for anything that could interfere with optical drives and mounting
    - Disabled explorer's CD writing service from gpedit.msc
    - Changed drive letters so that virtual drive letter (B:\) comes before USB HDD (E:\)
    - Reverted drive letter etc. options by deleting the correct registry tree that handles them and restarting (This one I was very sceptical about and did correct backups so I do not mess anything up. Cannot remember path of the key.)
    - Tried deleting Upper and Lower filters from HKEY_Local_Machine/system/current control set/control/Class/{4d36e965-e325-11ce-bfc1-08002be10318} but neither existed for that key
    - Ran sfc /scannow to verify integrity.
    - Ran DISM with /repairhealth

    - Tried DVD's with external USB DVD drive. Behaves identically compared to the internal drive.
    - Confirmed the tested DVD's working on Xbox360

    The straightforward solution is ofc to reinstall windows but I do not want to do it, there should be another way.
    Any ideas on what to try next? Anything I have missed? The Windows FixIt program has also provided a solution to people that cannot read DVD's but it is not available for my OS. I know there are others out there with the identical problem.
    Last edited by Kese; 24 Feb 2014 at 21:00.

      My System SpecsSystem Spec

W8.1 Cannot read physical or mounted DVD's
Related Threads
Can't open my mounted vhdx backup image in Performance & Maintenance
I can't open the mounted image in the disk management console. This is my backup image from my previous win 8.1 pro x64 system. Its stored on a external hdd w/ bit locker protection. My problem is I want to recover some files from the previous image but when I mount the vdhx image, the "Open", when...
Physical Memory Full in Performance & Maintenance
Help, my physical memory is at 97% all of a sudden and causing major lag in games. Nothing in the task manager is using that much memory so I don't know what's causing it. I have Windows 8.1 with 8 gigs. Edit: I tried to restart and there is one app that isn't closing and preventing it from...
Hey guys!! I have dual booted my lappy with win7 ultimate and win8 pro using vhd.i have installed windows8 on vhd,but due to that i can't use the fast start and system rating in i want to restore my win8 vhd to my hardisk.pls help me.I have 4 partitions on my hardisk i can use any one of...
Physical Disk in VMware in Virtualization
Hi. Objective: Putting as physical disk from the host's partitions. Device and Software Availability:Windows 8, VMware workstation build 10, USB optical Drive, Result: 32845
In Windows 8.1, when I try to use the native ISO mounting function, either from the right-click menu, or by double clicking the iso file, I am getting the error: Couldn't Mount File Sorry, there was a problem mounting the file. Yet most of the time, the virtual CD/DVD drive appears as it ...
I use O&O Disk Image 7.2 to make images of my Windows 8 drive. Occasionally I need to mount an image to access folders and files. One folder I can't access is my user folder. I get the message 'You don't currently have permission to access this folder.' I took ownership of the folder but that...
I'm new here, so please bear with me if this post is in the wrong section or place. I am currrently using a Dell Precision 690 with 2 physical CPUs and a total of 4 cores. Win 7 x64 handles this with no problem. I am looking to obtain a new unit with a quad AMD Interlagos CPU with a total of 64...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook