Windows 8 and 8.1 Forums


USB flash drives takes long time to show up in explorer

  1. #1


    Posts : 2
    W7, W8

    USB flash drives takes long time to show up in explorer


    Hi,
    I'm running windows 8.1 x64. When I insert a usb flash drive into my PC, it takes maybe over 2 minutes before windows "finds" it and has it appear in windows explorer. I have no idea what to do about this. I have the latest BIOS for my motherboard and I don't think there are any specific usb drivers to install.

    thanks

      My System SpecsSystem Spec

  2. #2


    Posts : 2,130
    Windows 8.0 x64


    I assume you tried different ports and different sticks and have gotten the same results?

    Also System Specs will likely be helpful
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    W7, W8


    Yes, I've tried other ports and same behaviour. I just tried it again and it took 6min to show up. However, I found another usb flash drive and it worked fine.

    The flash drive is a Lexar 8GB, usb2 I think.
    I just remembered: I had previously used this usb flash drive as a ms-dos bootable drive. I've formatted it since. Disk manager only sees one FAT32 partition (the one I formatted).
      My System SpecsSystem Spec

USB flash drives takes long time to show up in explorer
Related Threads
After waking the computer it immediately shows that it's connected to the Wifi network, but I can't access the Internet. Hovering the mouse over the network icon in the taskbar shows me the following (see attached). Happens on all networks I've tried. After a minute or so it starts to work, but...
When I reboot Windows I get the login after approx 10 sec. But after I login it takes approx 25 sec for the network connection to get airborne --- first a red cross and then yellow triangle. Where is the bottleneck ? I have a fast Intel NIC and my LAN runs at 1 GBits and the Internet speed is...
Upgraded to 8.1 last weekend. Thought I'd got most of the wrinkles sorted but now a couple more have emerged. Discovered compatibility issues with Nuance Paperport 14. Removed and re-installed but to no avail. But since then boot up takes an inordinately long time. In addition Firefox doesn't...
Hello everyone, The attached video will NOT win the Youtube film of the year award, however, I hope that someone might be able to help. My Dell XPS8700 is like a 16 year old, friendly one minute and totally nuts the next for no reason at all! The computer DOES boot, but there's no beep and...
Hi I recently purchased alienware m18x r2 with following specs I7 3630m Gtx 680m sli 12gb ram 750gb wd 120 (windows installed) & 256gb sdd
Greetings. I have 2 PC's. Both are now running Windows 8. The main PC was running Windows 7 and I there mapped a network drive (z:) to the Win8 PC. It worked very nice. The second PC was also shown in "networks" in "my Computer" right after boot of Main PC. So network for sharing is set up...
Hi, I'm using Windows 8 Pro N with 32-bit. I found some problem SOMETIME whenever I tried to open My Computer, it takes a very long time to show up my drives and removable disks. 21505 Here's the screenshot of it. The Green Bars is moving damn slow, For sometime only. Besides, I also...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook