Windows 8 and 8.1 Forums


Touchpad not working after migrating from w7 to w8.1

  1. #1


    Posts : 7
    Win 7 / 8.1 64-bit

    Touchpad not working after migrating from w7 to w8.1


    Recently I've upgraded my toshiba laptop with w7 to w8.1 (without keeping any settings), but I cant get my synaptics touchpad to work.


    Windows automatically installed some drivers for the touchpad but it didnt work. Then I downloaded newest generic drivers from synaptics website but they wouldnt install - I get an "installation failed" error without any elaboration.

    So I've installed synaptics driver that was provided for my laptop for win 7. It installed nicely, but the touchpad still doesnt work - disabling/enabling it in synaptics tab in mouse settings doesnt change anything.

    I thought that maybe now the generic driver will install that I have an older synaptics version installed and not some random windows driver, but no, the installation still fails.

    The story unfolds :P Next I downloaded toshiba synaprics driver for win 8.1 that was developed for some newer laptop model as mine is no longer supported. The installation went smoothly but the touchpad still doesnt work.....


    I seriously need to get that thing working or revert to w7 because I cant risk being left with no mouse when batteries run out in my wireless mouse :/ Any ideas what to do?

      My System SpecsSystem Spec

  2. #2


    USA, CA
    Posts : 191
    WIN 7 PRO x64, WIN 8.1 PRO x64


    we need you to update your system specs in your profile so that we can direct you to the driver that you need for 8.1 as the one for 7 will not work most likely. we need the model of the laptop.
      My System SpecsSystem Spec

  3. #3


    Posts : 7
    Win 7 / 8.1 64-bit


    Well, it's toshiba L505D-10J (it seems that this model is a bit stronger than other 505's and was released only in my country).

    I didnt think that anything besides windows version really mattered in this matter (well maybe I could have added that its 64 bit), but I've updates my specs now.

    Also, in device manager theres following hardware ID given with touchpad :

    ACPI\VEN_SYN&DEV_0712
    ACPI\SYN0712
    *SYN0712
      My System SpecsSystem Spec

Touchpad not working after migrating from w7 to w8.1
Related Threads
Hi My netbook is a Samsung n145plus and has 8.1 installed with all updates. (even if it's not officially supported but it works amazingly fine) I've installed the officia Samsung Elan touchpad driver as it seemed to work fine (it's for Win 7) except when scrolling with the edge of the pad...
Hi all, These two pieces of hardware have been working intermittently for the past several months but now have failed completely. Device manager recognizes them as on and working properly but neither of them detect anything, which makes me suspect a ribbon cable or something similar. Any leads on...
A few days ago I formatted a drive and installed Win 8.1. Also installed all the drivers. Yesterday, when closing it downloaded some updates which it installed today. Now neither keyboard nor touchpad works. I connected a wireless keyboard but it won’t work either. Wired mouse does work. ...
Solved Asus touchpad stoped working... in Drivers & Hardware
My Aus K55a touchpad did nto work anymore. I rolled back the driver and it works. I have lost all the nice scrolling features and just have a basic mouse function. I uninstalled and reinstalled the driver with the same result everytime. It will work for about a minute and completly stop. ANy...
I have the keysonic ACK-340BT keyboard with touchpad and left-right buttons, i was using with an acer tablet and win 8. After upgrading to 8.1 the touchpad and buttons stopped working, rest of the keyboard works. tested on another 8.1 machine and same issue. So something changed from 8 to 8.1...
Touchpad Gestures Not Working in Drivers & Hardware
Hi, I've recently bought the Asus Vivobook S200, comes with Windows 8. When I first got it the touchpad gestures were working fine, then all of a sudden they just stopped working. This is within a few hours of purchasing it. Any ideas how to reenable the gestures for the touchpad? Thanks.
Hiya, I have a Dell Inpiron 15R SE which came with the 750GB WD HDD. I made an image of the system removed the HDD, Installed SSD and restored the image. Windows start up fine but there seems to be lots of small problems, The metro App store is not working and there are no Metro Apps in the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook