Windows 8 and 8.1 Forums

Vivotab RT not recognizing keyboards after 8.1 update

  1. #1

    Vivotab RT not recognizing keyboards after 8.1 update

    I have an Asus TF600T (Vivotab RT) that came with the Asus Keyboard Dock.

    I also already had the Microsoft Wedge bluetooth keyboard.

    I believe the last time I used with the Wedge keyboard or the Asus Kyeboard Dock SUCCESSFULLY was when I had RT 8.0 on this device.

    I have not had need to use the keyboard until the last few days. I updated my Vivotab RT to 8.1 about 6 weeks ago. Last week I took out the Asus Keyboard Dock and connected it and all the tablet would do is make clicking noises whenever I pressed any button. It would not recognize any keystrokes. I rebooted the tablet while connected to the dock and same problem. I thought maybe the Keyboard Dock needed to be charged so I did not think anything else about it and plugged it into the charger overnight to let it charge.

    I have not messed with that keyboard since that night. Tonight I get to work and I had 2 hours to kill so I decided to get my Wedge Keyboard that I have used with my Android tablet with no issues and on my RT I went into Bluetooth and paired the keyboard successfully. YES, it recognized the number code I was asked to type into the keyboard. Pair was successful and it said it was paired and it installed a driver (which looks good in device manager) but now this keyboard is behaving the same way. All the tablet is doing is clicking anytime I press a key on the keyboard. It will not recognize any keys for typing or anything else. Again, I rebooted the tablet and no help.

    I have a bluetooth mouse AND a bluetooth speaker which I HAVE been using successfully with my Vivotab RT for the last month and my bluetooth mouse which I have here at work is working fine on the tablet. I did go ahead and delete all the blueooth devices, turn the bluetooth off and on, reboot the tablet, re-paired the keyboard, successfully paired it.. and now it's back to just making the tablet click.

    Any thoughts?

    My USB dongle is at home so I cannot test a standard USB keyboard until I get home in the morning.

      My System SpecsSystem Spec

  2. #2

    I just remembered, the hardware WINDOWS button on the bottom on the tablet also has not worked since I updated to RT 8.1. It had been just making the tablet BUZZ without functioning but NOW its clicking when I press it like the keyboard had been doing. Bad tablet?
      My System SpecsSystem Spec

  3. #3

    I am Woman! Hear Me Roar!
    Posts : 1,116
    4 Windows 7 Pro Sp1- 4 Win 8 Pro, 1- xp pro sp3

    Asus has an update to their windows 8 tablets when upgrading to 8.1. I have the asus vivo smart tablet. There is an icon on the desktop or on the metro screen for it
    Try doing the update, it might fix your problem. I found it fixed a bunch of mine when i did this update after doing 8.1. There is also a bios update which fixed my bluetooth problem i jad
      My System SpecsSystem Spec

  4. #4

    Thanx for the reply Robin.

    There is no such icon on my Start menu. There have been several Windows Updates and
    patches provided since the update to 8.1 and I have applied them all.

    To my own detriment, I have applied several registry hacks to speed up response time on
    my tablet. Its quite possible one of these hacks simply broke Windows.

    I am now performing a complete format and re-install of Windows RT to see if that will fix it.

    If not, its under warranty and I'll have to take it up with Asus.

    Thanx again.
    ***Update -

    After the re-install the keyboard starting working. So, I will have to be more careful when I make changes
    and test my keyboard to be sure anything I do doesn't interfere with it again.

    If I discover which edit caused the problem I will share it here. Oh, the hardware
    WINDOWS button on the bottom center of the tablet still does not work. I can't say if it ever
    worked since I got the unit. Oh well.
    Last edited by orlandotek; 19 Dec 2013 at 22:55.
      My System SpecsSystem Spec

Vivotab RT not recognizing keyboards after 8.1 update
Related Threads
Version: 8.1, 8.1.1 This issue has been for quite sometime. Not sure if anyone else too faced this. When updates from windows-updated are installed (which requires reboot), the "Restart now" button appears after installation. However, I decided not to restart at that time. After completing my...
So I'm looking for some kind of maths keyboard which I can use to easily add maths symbols to my lecture notes. Best way I could think of doing this is with the touch keyboard. With the touch keyboard you can hit the little keyboard button bottom left and change between a regular keyboard, split...
My BT keyboard is no longer discoverable by my ASUS Vivotab ME 400C. Seemed to suddenly stop working after a couple of incidents where a letter would be repeated 1 hundred times. (i.e. "eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee" for "e") The keyboard was recognized by my Blackberry and is working....
VivoTAB Smart LTE problem after 8.1 in BSOD Crashes and Debugging
Hello everyone. After installing Windows 8.1 I have a problem with the wake-up device. My tablet goes to sleep, when I wake it up I have to wait a few seconds until the display driver will respond. Log Name: System Source: Display Date: 2013-10-19 11:45:29 p.m. Event ID: 4101 Task...
Just curious if it's possible or would be possible in the future to download and install customized virtual keyboards to Windows 8. Especially when using Gaming Emulators that only require maybe 8 keys to substitute as buttons. Would be cool to gain back some screen real-estate. ...
I am about to buy a Logitech MK550 combo and wanted to make sure it works on my W8 RTM.
Read more at source: Personal computing in the future: of mice and keyboards | ZDNet
Eight Forums Android App Eight Forums IOS App Follow us on Facebook