Hi there,

After upgrading to Windows 8.1, (also happened in 8) I'm having a problem with my USB3 Seagate External HDD.

For some reason my computer is not finding the drive after it's been switched off. I have to unplug-and re-plug in the USB lead for computer to recognise it. It's fine after a reboot - just a full shutdown causes the problem.

This causes a few annoying error messages on startup as I have both iCloud, and Dropbox set to this External drive. The problem did not occur in Windows 7.

I've tried disabling the "Automatically Switch this USB device off to save power" setting. Also downloaded Seatools software to ensure the drive never "Sleeps". Nothing has worked yet. Trying a different USB port gives same results. No other USB device has any problems during startup.

Motherboard is a Gigabyte GA-Z77X-UD5H-WB WIFI.
HDD is a Seagate External 2TB.

I did try (as a last resort) using the Windows 7 USB3 drivers instead of the "built in" native USB3 support that Windows 8 provides. This didn't seem to work.

Any help / tips / ideas greatly appriciated!