Windows 8 and 8.1 Forums


Help Needed - No display at all, possibly missing drivers

  1. #1


    Posts : 20
    Windows 8

    Help Needed - No display at all, possibly missing drivers


    I believe i have royally screwed myself over. I recently bought a windows 8 gateway desktop computer, with an AMD processor and integrated video. I installed an external video card to compare the baseline and performance to the integrated one. After realizing it wasn't as good. I removed it and got the integrated one working again. but then I uninstalled the nvidea drivers and turned off my computer for the night. Ever since that night, no matter what i do, i cannot get any display to appear on the monitor.

    I have tried many many different things suggested in forums to help fix this issue. Any suggestions would be greatly appreciated, but i am strongly considering bringing it in to the source where i bought it and having them reset it or something.

    This is my first post on the forums btw so any criticism on that regard is also welcome.

    Thank you

      My System SpecsSystem Spec

  2. #2


    USA, CA
    Posts : 191
    WIN 7 PRO x64, WIN 8.1 PRO x64


    can you start your os in safemode? does it show anything on the screen at post? How To Boot Into Windows 8 Safe Mode | Redmond Pie
      My System SpecsSystem Spec

  3. #3


    Posts : 20
    Windows 8


    Noo. It beeps when i press the f12 or f8 key on startup, shows the Gateway loading screen, then starts blinking a black screen like it always does. I've even tried loading a windows 8 recovery onto a flash and booting from that but i can't see anything to know whether or not i am booting from it or even at the boot menu or bios.
      My System SpecsSystem Spec

  4. #4


    USA, CA
    Posts : 191
    WIN 7 PRO x64, WIN 8.1 PRO x64


    can we have the model of the computer please? seems that either you might be hitting the wrong key (must be shift+ tapping f8) or your bios is expecting a external card and needs to be set back to integrated.
      My System SpecsSystem Spec

  5. #5


    Posts : 20
    Windows 8


    The model # is: DX4380-ER24
    I will attempt shift+f8.
    If it needs to be set back to integrated, is that possible to do without seeing anything on screen?
      My System SpecsSystem Spec

  6. #6


    Suggestion: Pull the CMOS battery out for 5 minutes. First completely unplug PC from power source and if the PSU has a on/off switch turn it off as well. Pull side panel off, find CMOS battery and remove it for 5 minutes. Then re-install the CMOS battery re-attach power cord and turn switch on the PSU to on, then power up and you should have your monitor back online.
      My System SpecsSystem Spec

  7. #7


    Posts : 20
    Windows 8


    As i am not very familiar with hardware, how do i identify the CMOS battery?

    and RVCJEW, shift+f8 did not do anything different, thank you for the suggestion though.
      My System SpecsSystem Spec

  8. #8


    Posts : 20
    Windows 8


    I googled how to locate it. I have found it and removed it with ease. I will let you know in 5-10 minutes whether or not this worked. Thank you again for the suggestion. My fingers are crossed
      My System SpecsSystem Spec

  9. #9


    Posts : 20
    Windows 8


    It did not work. I can now see the gateway loading screen on startup, but as soon as that leaves, it goes right back to the blinking black screen.
      My System SpecsSystem Spec

  10. #10


    Reboot and at the gateway loading screen hit the F1 or F2 key to get into the BIOS. Then set the BIOS to the default settings.

    ???????????????????????????? should say how to enter the BIOS


    ???????????????????????????????????????????? FAQ


    You have to constantly tap the F1 key until the screen changes if the F1 key doesn't work do the same for the F2 key.
      My System SpecsSystem Spec

Page 1 of 4 123 ... LastLast
Help Needed - No display at all, possibly missing drivers
Related Threads
Hello all, for a'while I had been wondering why there were so many grayed out and seemingly out of place drivers on my laptop. For them to be grey, I assume they simply are not being used at the moment. I believe they may have been the leftovers from the stress testers and the tech team that worked...
Solved BSOD possibly due to corrupted memory drivers in BSOD Crashes and Debugging
I asked my question on micorsoft community but they answered a few times then simply stopped answering, all I was told is that it maybe possibly due to corrupted memory drivers. I either get the BSOD with the DPC_Watchdog_Violation error or my laptop just freezes and a constant buzzing sound...
Window 8.1 Drivers Help Needed in General Support
I am going to install window 8.1 previously I have window 7 preinstalled by dell.....now I want drivers for various factory fitted hardwares but on dell support website for my model no there is no option for divers on window 8 os my model number is Studio1457 help will really be appreciated..
I bought a 1 TB WD10EZEX OEM for storage with a SSD but the SSD died before it arrived. The only problem I could imagine is the intel DG33FB mobo specs are 3.0 mbps while this one is 6.0 mbps. But I think it is backwards compatiable. I installed new hdd and started installing 7 so that I could...
No drivers needed???? in Drivers & Hardware
Hello to all my sevenforum mates. I just installed Win8 CP on my Intel320 SSD. Interesting OS so far. I have not installed any drivers and everything is working perfect- so far. :confused: Strange. I'm not sure where I would install them or where to check. Where the heck is the Start...
My CPU cooler, an Antec Khuler H2O 920, is powered by internal USB 2.0. This allows the radiator and fans to be controlled from a program inside Windows (ChillControl). The fans and radiator pump work, but I am unable to get the fans to run any faster than idle (this is important for doing anything...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook