Windows 8 and 8.1 Forums

Weird USB Problem

  1. #1


    Posts : 2
    Windows 8 - x64

    Weird USB Problem


    Heya, I've got weird USB problems, and can't seem to work out what's wrong.

    I'm using Windows 8 x64, all updated, which had been working without problem for about 8 months now.

    I noticed my internel card reader drives (9 pin USB header) kept disappearing and reappearing quickly, in both My Computer, and Device Manager. So I assumed it was dying and bought a new one, but it too did the same thing, so assumed it must be the USB connecter dying, and left it unplugged, and orderd an external card reader (yet to arrive).

    Sadly my USB flash drives and USB hard drives started doing the same thing, front and back ports, these drives will disappear and reappear a few times then work as normal, weird thing is my USB printer, mouse, keyboard, and Sansa Clip+ work fine.

    I tried testing in WinPE v4, and Linux (Ubuntu LiveCD) and everything seems to be working fine, including the internel card reader. So I reinstalled Windows 8 after trying fixes like uninstalling the USB Root entries in Device Manager, and messing with the USB power saving options in Windows, even though they're at the defaults and never caused problems before, but the internel card reader was doing the same thing again before even doing any updates, or installing drivers.

    I have found a workaround for the reader, if I disable it within Device Manger before putting a card in, and then enabling the device it works, but once ejected it goes back to disappearing and reappearing again.

    The PC is a Dell Inspiron 531, yep it's old.

      My System SpecsSystem Spec

  2. #2


    If all the usb peripherals work using the WinPE and Linux live cd.....that tells me it's not a hardware issue. This means a few things, it could be a software related issue which could be anything from a missing/corrupt system file to an OS update. The other thing is a Virus or a bug of some kind which are known to disable such input connections.

    I'd check your system for a Virus, trojan, worm with any all the software you have.

    Also, check for said issue in safemode.
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    Windows 8 - x64


    Hmm, but I did say I reinstalled, and the problem was still there before doing any updates, or driver installs. The medium used for the install worked before without issue, and I even reburnt the ISO, after checking its hash to make sure it wasn't damaged.

    Install medium is a ISO created with Windows8-Setup, when I did this I hashed the ISO.
      My System SpecsSystem Spec

Weird USB Problem
Related Threads
Help - weird problem in General Support
I had a 2TB WD Black HD that was developing bad sectors, so I decided to replace it with a WD Velociraptor 1 TB HD. Everything seemed fine., though I didn't do a lot on the computer so I can't say for sure. Power outage the next night. Starting the next day, the computer boots up and shuts down...
Weird Problem in Network & Sharing
First off I have 5 Windows computers in my house. 3 with 8.1, and 2 with Windows 7. I have an ASUS RT-AC66U wireless router that supports A, B, G, N, & AC. My problem is with my HP 7520 All-In-One printer hooked up wirelessly. With all the pc's off and the printer on in standby mode, I can start...
I have this weird problem in General Support
Hi I have this really weird problem. I recently upgraded my laptop to Windows 8. Everything went fine and there was no problem whatsoever. But recently, all the buttons inside the Metro (or, Modern) UI have disappeared. Either it shows only the outside ring with the insides blank, or boxes(like...
Solved Weird printer problem in Drivers & Hardware
I have a Canon MP990 All-in-One which has been working perfectly from when I installed the Canon drivers on my new home build W8 64bitpc a few weeks ago. This included successfully printing pdf files via the W8 Reader App. I set up the MP990 to always show a print preview before printing. All...
Solved Weird Problem in General Support
I'm having an issue I've never seen before. It seems to happen maybe a couple times a day (haven't paid that close attention yet). I'll be sitting there and notice the hard drive activity light is on steady and won't even blink. I can work on the system normally though. However when I try to...
Weird Weird Problem! in Network & Sharing
I have the strangest problem with my internet since updating to W8. My internet works absolutely fine all day, up until later in the day (not sure what time exactly this happens) but it stops working! It says it is connected but it simple can't find a network. I am connected via LAN to an...
Running W8 Pro x64 RTM (from Technet) I'm having a weird problem that I can't seem to pin down the cause. Whenever I run Task Scheduler, Print Management, or Event viewer and then exit them, a folder is created on my desktop called 'Administrative Tools' Clicking on this folder opens up...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook